summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 00:26:49 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:14:17 +0200
commitd4ffa9630277fa8699c783c08381d688626d4bc3 (patch)
treeb0cde865c3a733e2cf21e39acb3c3806c0464412 /gnu/packages/patches
parentd58e2f2723cb97954837821e425324fa34ab6ddf (diff)
downloadguix-patches-d4ffa9630277fa8699c783c08381d688626d4bc3.tar
guix-patches-d4ffa9630277fa8699c783c08381d688626d4bc3.tar.gz
gnu: autotrace: Prepare for GLib 2.68 and later.
* gnu/packages/patches/autotrace-glib-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (autotrace)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/autotrace-glib-compat.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/autotrace-glib-compat.patch b/gnu/packages/patches/autotrace-glib-compat.patch
new file mode 100644
index 0000000000..e63dcedf83
--- /dev/null
+++ b/gnu/packages/patches/autotrace-glib-compat.patch
@@ -0,0 +1,50 @@
+Fix build with GLib 2.68 and later.
+
+Taken from upstream pull request:
+https://github.com/autotrace/autotrace/pull/41
+
+diff --git a/src/autotrace.h b/src/autotrace.h
+--- a/src/autotrace.h
++++ b/src/autotrace.h
+@@ -23,6 +23,9 @@
+
+ #include <stdio.h>
+
++#include "types.h"
++#include "color.h"
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif /* __cplusplus */
+@@ -35,9 +38,6 @@ extern "C" {
+ * Typedefs
+ * ===================================================================== */
+
+-#include "types.h"
+-#include "color.h"
+-
+ /* Third degree is the highest we deal with. */
+ enum _at_polynomial_degree {
+ AT_LINEARTYPE = 1,
+diff --git a/src/color.h b/src/color.h
+--- a/src/color.h
++++ b/src/color.h
+@@ -24,6 +24,10 @@
+ #include <glib.h>
+ #include <glib-object.h>
+
++#ifdef __cplusplus
++extern "C" {
++#endif /* __cplusplus */
++
+ typedef struct _at_color at_color;
+ struct _at_color {
+ guint8 r;
+@@ -43,4 +47,7 @@ void at_color_free(at_color * color);
+ GType at_color_get_type(void);
+ #define AT_TYPE_COLOR (at_color_get_type ())
+
++#ifdef __cplusplus
++}
++#endif /* __cplusplus */
+ #endif /* not AT_COLOR_H */