summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2016-04-27 23:33:56 +0300
committerManolis Ragkousis <manolis837@gmail.com>2016-05-04 17:18:57 +0300
commitd46123aade7bc5226004eb46ee1084dc84f2b30a (patch)
tree890ba4958d75e10ec3a7aa8ff71b2fecc7026063 /gnu/packages/patches
parentb5e0c870cb2c4a6864455308c74684fd024f101f (diff)
downloadguix-patches-d46123aade7bc5226004eb46ee1084dc84f2b30a.tar
guix-patches-d46123aade7bc5226004eb46ee1084dc84f2b30a.tar.gz
gnu: procps: Make procps build on non Linux systems.
* gnu/packages/patches/procps-non-linux.patch.patch: New patch. * gnu/packages/linux.scm (procps)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/procps-non-linux.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/procps-non-linux.patch b/gnu/packages/patches/procps-non-linux.patch
new file mode 100644
index 0000000000..9d369aeb2c
--- /dev/null
+++ b/gnu/packages/patches/procps-non-linux.patch
@@ -0,0 +1,40 @@
+From aa9bd38d0a6fe53aff7f78fb2d9f61e55677c7b5 Mon Sep 17 00:00:00 2001
+From: Craig Small <csmall@enc.com.au>
+Date: Sun, 17 Apr 2016 09:09:41 +1000
+Subject: [PATCH] tests: Conditionally add prctl to test process
+
+prctl was already bypassed on Cygwin systems. This extends to
+non-Linux systems such as kFreeBSD and Hurd.
+
+---
+ lib/test_process.c | 4 ++--
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/lib/test_process.c b/lib/test_process.c
+index 6e652ed..6a4776c 100644
+--- a/lib/test_process.c
++++ b/lib/test_process.c
+@@ -21,7 +21,9 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
++#ifdef __linux__
+ #include <sys/prctl.h>
++#endif
+ #include "c.h"
+
+ #define DEFAULT_SLEEPTIME 300
+@@ -78,8 +80,10 @@
+ sigaction(SIGUSR1, &signal_action, NULL);
+ sigaction(SIGUSR2, &signal_action, NULL);
+
++#ifdef __linux__
+ /* set process name */
+ prctl(PR_SET_NAME, MY_NAME, NULL, NULL, NULL);
++#endif
+
+ while (sleep_time > 0) {
+ sleep_time = sleep(sleep_time);
+--
+2.8.2
+