summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2022-06-21 16:12:47 +0200
committerAndreas Enge <andreas@enge.fr>2022-06-21 16:12:47 +0200
commitd13ffd1580ec2253b6e05fb6300c3629aee893e3 (patch)
treeba8c21630ab1694ee0ece567dfbddd5d4afc62de /gnu/packages/patches
parent0fe0c739f53bbb635eb5c4a3b172f4be45293c82 (diff)
downloadguix-patches-d13ffd1580ec2253b6e05fb6300c3629aee893e3.tar
guix-patches-d13ffd1580ec2253b6e05fb6300c3629aee893e3.tar.gz
gnu: cmh: Add patch to work with current fplll.
* gnu/packages/patches/cmh-support-fplll.patch: New file. * gnu/packages/algebra.scm (cmh)[source]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cmh-support-fplll.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/cmh-support-fplll.patch b/gnu/packages/patches/cmh-support-fplll.patch
new file mode 100644
index 0000000000..fae04f456b
--- /dev/null
+++ b/gnu/packages/patches/cmh-support-fplll.patch
@@ -0,0 +1,27 @@
+Patch from the CMH git, after the 1.1.0 release.
+
+From 2328c819317dda2171217002268f57c74cedc476 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Emmanuel=20Thom=C3=A9?= <Emmanuel.Thome@inria.fr>
+Date: Tue, 7 Jun 2022 12:17:05 -0700
+Subject: [PATCH] patch suggested by @x-YVicto
+
+---
+ src/lll.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lll.cpp b/src/lll.cpp
+index 83dab07..f005931 100644
+--- a/src/lll.cpp
++++ b/src/lll.cpp
+@@ -37,7 +37,7 @@
+ #ifdef HAVE_FPLLL
+ static void lll_fplll (mpz_t *v, mpz_t **M, const int m, const int n)
+ {
+- ZZ_mat <mpz_t> Mp (m, n);
++ fplll::ZZ_mat <mpz_t> Mp (m, n);
+ int i, j;
+
+ for (i = 0; i < m; i++)
+--
+2.36.1
+