summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-30 23:42:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 00:49:15 +0100
commitc7164ad65fcad1df51d1647833326f436b70fb2c (patch)
treefe7f9a042fbead6fee9473c59d31f29767d127cc /gnu/packages/patches
parent9530c4bfc92655cee4beac610258ac3bfc489501 (diff)
downloadguix-patches-c7164ad65fcad1df51d1647833326f436b70fb2c.tar
guix-patches-c7164ad65fcad1df51d1647833326f436b70fb2c.tar.gz
gnu: fcgi: Update to 2.4.2.
* gnu/packages/web.scm (fcgi): Update to 2.4.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. Remove obsolete patches. [native-inputs]: Add autoconf, automake, and libtool. * gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch, gnu/packages/patches/fcgi-2.4.0-poll.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch14
-rw-r--r--gnu/packages/patches/fcgi-2.4.0-poll.patch89
2 files changed, 0 insertions, 103 deletions
diff --git a/gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch b/gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch
deleted file mode 100644
index 0f921b120b..0000000000
--- a/gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-gcc44_fixes.patch.
-Fixes compilation with GCC 4.4 and later.
-
-diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
---- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
-+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
-@@ -23,6 +23,7 @@
- #endif
-
- #include <limits.h>
-+#include <cstdio>
- #include "fcgio.h"
-
- using std::streambuf;
diff --git a/gnu/packages/patches/fcgi-2.4.0-poll.patch b/gnu/packages/patches/fcgi-2.4.0-poll.patch
deleted file mode 100644
index 73be6a0a08..0000000000
--- a/gnu/packages/patches/fcgi-2.4.0-poll.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-poll.patch
-Fixes CVE-2012-6687.
-
-Author: Anton Kortunov <toshic.toshic@gmail.com>
-Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
-Description: use poll in os_unix.c instead of select to avoid problem with > 1024 connections
-Forwarded: yes, fastcgi-developers@mailman.fastcgi.com
-
-diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
-index 73e6a7f..af35aee 100755
---- a/libfcgi/os_unix.c
-+++ b/libfcgi/os_unix.c
-@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
- #include <sys/time.h>
- #include <sys/un.h>
- #include <signal.h>
-+#include <poll.h>
-
- #ifdef HAVE_NETDB_H
- #include <netdb.h>
-@@ -103,6 +104,9 @@ static int volatile maxFd = -1;
- static int shutdownPending = FALSE;
- static int shutdownNow = FALSE;
-
-+static int libfcgiOsClosePollTimeout = 2000;
-+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
-+
- void OS_ShutdownPending()
- {
- shutdownPending = TRUE;
-@@ -168,6 +172,16 @@ int OS_LibInit(int stdioFds[3])
- if(libInitialized)
- return 0;
-
-+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
-+ if(libfcgiOsClosePollTimeoutStr) {
-+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
-+ }
-+
-+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
-+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
-+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
-+ }
-+
- asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
- if(asyncIoTable == NULL) {
- errno = ENOMEM;
-@@ -755,19 +769,16 @@ int OS_Close(int fd)
-
- if (shutdown(fd, 1) == 0)
- {
-- struct timeval tv;
-- fd_set rfds;
-+ struct pollfd pfd;
- int rv;
- char trash[1024];
-
-- FD_ZERO(&rfds);
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
- do
- {
-- FD_SET(fd, &rfds);
-- tv.tv_sec = 2;
-- tv.tv_usec = 0;
-- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
-+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
- }
- while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
- }
-@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
- */
- static int is_af_unix_keeper(const int fd)
- {
-- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
-- fd_set read_fds;
--
-- FD_ZERO(&read_fds);
-- FD_SET(fd, &read_fds);
-+ struct pollfd pfd;
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
-- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
-+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
- }
-
- /*