summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-27 03:40:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-27 04:25:24 +0200
commitc64f0eea880efa4953cce93f293b2935b45b9721 (patch)
tree7989e24a103d3974e1c31359172a2fcf8d954eb9 /gnu/packages/patches
parent083bc36215198298510f64757e299ac2edb76569 (diff)
downloadguix-patches-c64f0eea880efa4953cce93f293b2935b45b9721.tar
guix-patches-c64f0eea880efa4953cce93f293b2935b45b9721.tar.gz
gnu: python-jedi: Update to 0.17.2.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.17.2. [source, arguments]: Remove upstreamed patching. * gnu/packages/patches/python-jedi-sort-project-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-jedi-sort-project-test.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/python-jedi-sort-project-test.patch b/gnu/packages/patches/python-jedi-sort-project-test.patch
deleted file mode 100644
index b2d602dfe6..0000000000
--- a/gnu/packages/patches/python-jedi-sort-project-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Sort the result of file system traversal to avoid test failure on different
-file systems.
-
-Taken from upstream:
-https://github.com/davidhalter/jedi/commit/7ff76bb7d0d94514e17cd1647f4ffaf533dd55f5
-
-diff --git a/test/test_api/test_project.py b/test/test_api/test_project.py
---- a/test/test_api/test_project.py
-+++ b/test/test_api/test_project.py
-@@ -135,7 +135,7 @@ def test_search(string, full_names, kwargs, skip_pre_python36):
- defs = project.complete_search(string, **kwargs)
- else:
- defs = project.search(string, **kwargs)
-- assert [('stub:' if d.is_stub() else '') + d.full_name for d in defs] == full_names
-+ assert sorted([('stub:' if d.is_stub() else '') + d.full_name for d in defs]) == full_names
-
-
- @pytest.mark.parametrize(