summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-02-07 16:06:17 -0800
committerVagrant Cascadian <vagrant@debian.org>2020-02-07 16:06:17 -0800
commitc526ddf482618edd22d0ad852e13f63c0477bb77 (patch)
tree381276bcca1e943b6db6bac83287860bab558e8e /gnu/packages/patches
parentd9e2f7b284f124b48b9fee150a3c06b5e0170049 (diff)
downloadguix-patches-c526ddf482618edd22d0ad852e13f63c0477bb77.tar
guix-patches-c526ddf482618edd22d0ad852e13f63c0477bb77.tar.gz
gnu: Add reprotest.
Added to diffoscope, to avoid triggering #37346. * gnu/packages/diffoscope (reprotest): New variable. * gnu/packages/patches/reprotest-support-guix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/reprotest-support-guix.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/gnu/packages/patches/reprotest-support-guix.patch b/gnu/packages/patches/reprotest-support-guix.patch
new file mode 100644
index 0000000000..621c4e3359
--- /dev/null
+++ b/gnu/packages/patches/reprotest-support-guix.patch
@@ -0,0 +1,79 @@
+From 31bd4fe777cbff3ebca74115e5735a8b8f584fa7 Mon Sep 17 00:00:00 2001
+From: Vagrant Cascadian <vagrant@reproducible-builds.org>
+Date: Thu, 6 Feb 2020 23:17:58 -0800
+Subject: [PATCH] Add support for GNU Guix.
+
+---
+ reprotest/lib/adt_testbed.py | 2 ++
+ reprotest/lib/system_interface/guix.py | 39 ++++++++++++++++++++++++++
+ 2 files changed, 41 insertions(+)
+ create mode 100644 reprotest/lib/system_interface/guix.py
+
+diff --git a/reprotest/lib/adt_testbed.py b/reprotest/lib/adt_testbed.py
+index ef704d6..60bf763 100644
+--- a/reprotest/lib/adt_testbed.py
++++ b/reprotest/lib/adt_testbed.py
+@@ -40,6 +40,7 @@ import urllib.parse
+ from reprotest.lib.system_interface.debian import DebianInterface
+ from reprotest.lib.system_interface.arch import ArchInterface
+ from reprotest.lib.system_interface.fedora import FedoraInterface
++from reprotest.lib.system_interface.guix import GuixInterface
+ from reprotest.lib import adtlog
+ from reprotest.lib import VirtSubproc
+
+@@ -47,6 +48,7 @@ SYSTEM_INTERFACES = {
+ 'debian': DebianInterface,
+ 'arch': ArchInterface,
+ 'fedora': FedoraInterface,
++ 'guix': GuixInterface,
+ }
+
+ timeouts = {
+diff --git a/reprotest/lib/system_interface/guix.py b/reprotest/lib/system_interface/guix.py
+new file mode 100644
+index 0000000..2b06104
+--- /dev/null
++++ b/reprotest/lib/system_interface/guix.py
+@@ -0,0 +1,39 @@
++# adt_testbed.py is part of autopkgtest
++# autopkgtest is a tool for testing Debian binary packages. The
++# system_interface module is an addition for reprotest to make
++# this module distro-agnostic
++#
++# autopkgtest is Copyright (C) 2006-2015 Canonical Ltd.
++# the system_interface module is Copyright (C) 2017 Santiago Torres-Arias
++#
++# This program is free software; you can redistribute it and/or modify
++# it under the terms of the GNU General Public License as published by
++# the Free Software Foundation; either version 2 of the License, or
++# (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
++#
++# See the file CREDITS for a full list of credits information (often
++# installed as /usr/share/doc/autopkgtest/CREDITS).
++import subprocess
++
++from . import SystemInterface
++
++class GuixInterface(SystemInterface):
++ """
++ SystemInterface implementation for GNU Guix hosts. Contains commands that
++ are specific to the GNU Guix toolchain.
++ """
++
++ def get_arch(self):
++ return ['uname', '-m']
++
++ def can_query_packages(self):
++ return False
+--
+2.20.1
+