summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-04 13:07:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-04 22:06:24 +0100
commitc2d7e800e6788277bc56f31d5836f9d507dc1506 (patch)
tree6899a478600309b64dd1048a7030fade7acef7a4 /gnu/packages/patches
parentd3c1e9272d3004b8f737104c292f7b31393a091d (diff)
downloadguix-patches-c2d7e800e6788277bc56f31d5836f9d507dc1506.tar
guix-patches-c2d7e800e6788277bc56f31d5836f9d507dc1506.tar.gz
gnu: ceph: Update to 14.2.8.
* gnu/packages/patches/ceph-boost-compat.patch, gnu/packages/patches/ceph-volume-respect-PATH.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/storage.scm (ceph): Update to 14.2.8. [source](patches): Remove obsolete.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ceph-boost-compat.patch81
-rw-r--r--gnu/packages/patches/ceph-volume-respect-PATH.patch22
2 files changed, 0 insertions, 103 deletions
diff --git a/gnu/packages/patches/ceph-boost-compat.patch b/gnu/packages/patches/ceph-boost-compat.patch
deleted file mode 100644
index b3df659d6b..0000000000
--- a/gnu/packages/patches/ceph-boost-compat.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-Fix compatibility with Boost 1.70.
-
-Adapted for 14.2.5 from these upstream commits:
-https://github.com/ceph/ceph/commit/064f142746ae97f54865069cdacf5aae2b1b14f6
-https://github.com/ceph/ceph/commit/f1651b8c509d60787d10c4115e29fecfd2da237c
-
-diff --git a/src/rgw/rgw_asio_frontend.cc b/src/rgw/rgw_asio_frontend.cc
---- a/src/rgw/rgw_asio_frontend.cc
-+++ b/src/rgw/rgw_asio_frontend.cc
-@@ -83,7 +83,8 @@
- using SharedMutex = ceph::async::SharedMutex<boost::asio::io_context::executor_type>;
-
- template <typename Stream>
--void handle_connection(RGWProcessEnv& env, Stream& stream,
-+void handle_connection(boost::asio::io_context& context,
-+ RGWProcessEnv& env, Stream& stream,
- parse_buffer& buffer, bool is_ssl,
- SharedMutex& pause_mutex,
- rgw::dmclock::Scheduler *scheduler,
-@@ -160,7 +161,7 @@
- rgw::io::add_conlen_controlling(
- &real_client))));
- RGWRestfulIO client(cct, &real_client_io);
-- auto y = optional_yield{socket.get_io_context(), yield};
-+ auto y = optional_yield{context, yield};
- process_request(env.store, env.rest, &req, env.uri_prefix,
- *env.auth_registry, &client, env.olog, y, scheduler);
- }
-@@ -604,7 +605,7 @@
- return;
- }
- buffer->consume(bytes);
-- handle_connection(env, stream, *buffer, true, pause_mutex,
-+ handle_connection(context, env, stream, *buffer, true, pause_mutex,
- scheduler.get(), ec, yield);
- if (!ec) {
- // ssl shutdown (ignoring errors)
-@@ -622,7 +623,7 @@
- auto c = connections.add(conn);
- auto buffer = std::make_unique<parse_buffer>();
- boost::system::error_code ec;
-- handle_connection(env, s, *buffer, false, pause_mutex,
-+ handle_connection(context, env, s, *buffer, false, pause_mutex,
- scheduler.get(), ec, yield);
- s.shutdown(tcp::socket::shutdown_both, ec);
- });
-diff --git a/src/rgw/rgw_dmclock_async_scheduler.h b/src/rgw/rgw_dmclock_async_scheduler.h
---- a/src/rgw/rgw_dmclock_async_scheduler.h
-+++ b/src/rgw/rgw_dmclock_async_scheduler.h
-@@ -82,7 +82,12 @@ class AsyncScheduler : public md_config_obs_t, public Scheduler {
- using Completion = async::Completion<Signature, async::AsBase<Request>>;
-
- using Clock = ceph::coarse_real_clock;
-+#if BOOST_VERSION < 107000
- using Timer = boost::asio::basic_waitable_timer<Clock>;
-+#else
-+ using Timer = boost::asio::basic_waitable_timer<Clock,
-+ boost::asio::wait_traits<Clock>, executor_type>;
-+#endif
- Timer timer; //< timer for the next scheduled request
-
- CephContext *const cct;
-diff --git a/src/rgw/rgw_reshard.h b/src/rgw/rgw_reshard.h
---- a/src/rgw/rgw_reshard.h
-+++ b/src/rgw/rgw_reshard.h
-@@ -183,7 +183,14 @@ class RGWReshardWait {
- ceph::condition_variable cond;
-
- struct Waiter : boost::intrusive::list_base_hook<> {
-- boost::asio::basic_waitable_timer<Clock> timer;
-+#if BOOST_VERSION < 107000
-+ using Timer = boost::asio::basic_waitable_timer<Clock>;
-+#else
-+ using Executor = boost::asio::io_context::executor_type;
-+ using Timer = boost::asio::basic_waitable_timer<Clock,
-+ boost::asio::wait_traits<Clock>, Executor>;
-+#endif
-+ Timer timer;
- explicit Waiter(boost::asio::io_context& ioc) : timer(ioc) {}
- };
- boost::intrusive::list<Waiter> waiters;
diff --git a/gnu/packages/patches/ceph-volume-respect-PATH.patch b/gnu/packages/patches/ceph-volume-respect-PATH.patch
deleted file mode 100644
index 08a9a15ddd..0000000000
--- a/gnu/packages/patches/ceph-volume-respect-PATH.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Look for required tools in $PATH instead of just a handful locations.
-
-diff --git a/src/ceph-volume/ceph_volume/util/system.py b/src/ceph-volume/ceph_volume/util/system.py
-index b637f023a4..14516e1c65 100644
---- a/src/ceph-volume/ceph_volume/util/system.py
-+++ b/src/ceph-volume/ceph_volume/util/system.py
-@@ -33,14 +33,7 @@ def generate_uuid():
-
- def which(executable):
- """find the location of an executable"""
-- locations = (
-- '/usr/local/bin',
-- '/bin',
-- '/usr/bin',
-- '/usr/local/sbin',
-- '/usr/sbin',
-- '/sbin',
-- )
-+ locations = os.getenv('PATH').split(':')
-
- for location in locations:
- executable_path = os.path.join(location, executable)