summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-03-10 14:16:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-10 14:16:27 +0100
commitbda4b5e0453e4c8feda24306b4aa76ad5406eb7d (patch)
treec329ed45f3e95086a5acd11e8224cef5e2c25100 /gnu/packages/patches
parent1926db54a6a31f6676ba5db3668287ce7d709c8b (diff)
downloadguix-patches-bda4b5e0453e4c8feda24306b4aa76ad5406eb7d.tar
guix-patches-bda4b5e0453e4c8feda24306b4aa76ad5406eb7d.tar.gz
gnu: python: Fix cross-compilation.
This is a follow-up of 89da127035737bdf922bc566970c5506c2e01b00. * gnu/packages/patches/python-3-search-paths.patch: Use CROSS_C_INCLUDE_PATH instead of CROSS_CPATH.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 612201d1f2..df01d3b933 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -19,7 +19,7 @@ looking for headers and libraries.
+ self.lib_dirs = (os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep) +
sysroot_paths(('LDFLAGS', 'CC'), system_lib_dirs))
- self.inc_dirs = (self.compiler.include_dirs +
-+ self.inc_dirs = (os.getenv('CROSS_CPATH', '').split(os.pathsep) +
++ self.inc_dirs = (os.getenv('CROSS_C_INCLUDE_PATH', '').split(os.pathsep) +
sysroot_paths(('CPPFLAGS', 'CFLAGS', 'CC'),
system_include_dirs))