summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-04-01 22:50:56 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2021-04-02 09:23:20 +0100
commitbd9e14085668217b5657e57ca5b13a4a55360d9c (patch)
treee6abd3f7cc920a87b0510f96d5ba82e2d5780366 /gnu/packages/patches
parentd42f6b091660d1717064b2d75fe0c29a0c24f96a (diff)
downloadguix-patches-bd9e14085668217b5657e57ca5b13a4a55360d9c.tar
guix-patches-bd9e14085668217b5657e57ca5b13a4a55360d9c.tar.gz
Revert "gnu: libvirt: Update to 7.1.0."
The update causes virsh to fail <https://bugs.gnu.org/47541>. This reverts commit 383b02a370252c08eb1d43ac94d659c1d3993a35.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libvirt-create-machine-cgroup.patch48
-rw-r--r--gnu/packages/patches/libvirt-do-not-create-var-dirs.patch30
2 files changed, 48 insertions, 30 deletions
diff --git a/gnu/packages/patches/libvirt-create-machine-cgroup.patch b/gnu/packages/patches/libvirt-create-machine-cgroup.patch
new file mode 100644
index 0000000000..585ac237e1
--- /dev/null
+++ b/gnu/packages/patches/libvirt-create-machine-cgroup.patch
@@ -0,0 +1,48 @@
+From 9ca0b2955edea162b255b428e493cd8ffac52167 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miguel=20=C3=81ngel=20Arruga=20Vivas?=
+ <rosen644835@gmail.com>
+Date: Fri, 1 Nov 2019 17:29:00 +0100
+Subject: [PATCH] vircgroup: Ensure /machine group is associated with its
+ parent.
+
+Call first virCgroupNew on the parent group virCgroupNewPartition if
+it is available on before the creation of the child group. This
+ensures that the creation of a first level group on the unified
+architecture, as the check at virCgroupV2ParseControllersFile as the
+parent file is there.
+
+Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1760233
+---
+ src/util/vircgroup.c | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/src/util/vircgroup.c b/src/util/vircgroup.c
+index b46f20abfd..33c61f2d45 100644
+--- a/src/util/vircgroup.c
++++ b/src/util/vircgroup.c
+@@ -855,9 +855,6 @@ virCgroupNewPartition(const char *path,
+ if (virCgroupSetPartitionSuffix(path, &newPath) < 0)
+ goto cleanup;
+
+- if (virCgroupNew(-1, newPath, NULL, controllers, group) < 0)
+- goto cleanup;
+-
+ if (STRNEQ(newPath, "/")) {
+ char *tmp;
+ parentPath = g_strdup(newPath);
+@@ -868,7 +865,12 @@ virCgroupNewPartition(const char *path,
+
+ if (virCgroupNew(-1, parentPath, NULL, controllers, &parent) < 0)
+ goto cleanup;
++ }
+
++ if (virCgroupNew(-1, newPath, parent, controllers, group) < 0)
++ goto cleanup;
++
++ if (parent) {
+ if (virCgroupMakeGroup(parent, *group, create, VIR_CGROUP_NONE) < 0)
+ goto cleanup;
+ }
+--
+2.23.0
+
diff --git a/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch b/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
deleted file mode 100644
index 6b89d49fd4..0000000000
--- a/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-We define localstatedir as /var, and so we shouldn't be installing empty
-directories there.
-
-diff --git a/src/meson.build b/src/meson.build
-index f13b85b74e..58040f2c5d 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -893,22 +893,6 @@ if conf.has('WITH_DTRACE_PROBES')
- )
- endif
-
--
--# Install empty directories
--
--virt_install_dirs += [
-- localstatedir / 'cache' / 'libvirt',
-- localstatedir / 'lib' / 'libvirt' / 'images',
-- localstatedir / 'lib' / 'libvirt' / 'filesystems',
-- localstatedir / 'lib' / 'libvirt' / 'boot',
--]
--
--meson.add_install_script(
-- meson_python_prog.path(), python3_prog.path(), meson_install_dirs_prog.path(),
-- virt_install_dirs,
--)
--
--
- # Check driver files
-
- if host_machine.system() == 'linux'