summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-20 20:31:59 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-21 12:56:11 +0100
commitbbeb710de70521010b3d432cb5b4b14ce6e45ca6 (patch)
tree9101a4fb80afa9b16ebe56b074be73ad1ba60ac8 /gnu/packages/patches
parentf2c7513d1604076049d1834580d218d764e6b85b (diff)
downloadguix-patches-bbeb710de70521010b3d432cb5b4b14ce6e45ca6.tar
guix-patches-bbeb710de70521010b3d432cb5b4b14ce6e45ca6.tar.gz
gnu: Add hash-extender.
* gnu/packages/crypto.scm (hash-extender): New variable. * gnu/packages/patches/hash-extender-test-suite.patch: New file. * gnu/local.mk (dist_patch_DATA): Register the new file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hash-extender-test-suite.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/hash-extender-test-suite.patch b/gnu/packages/patches/hash-extender-test-suite.patch
new file mode 100644
index 0000000000..59de52dad4
--- /dev/null
+++ b/gnu/packages/patches/hash-extender-test-suite.patch
@@ -0,0 +1,13 @@
+Make the test suite exit with a non-zero exit code if some tests failed.
+Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
+--- a/test.c
++++ b/test.c
+@@ -79,5 +79,9 @@ void test_report(void)
+ printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
+ printf("--------------------------------------------------------------------------------\n");
+ }
++
++ if (tests_passed != tests_run) {
++ exit(1);
++ }
+ }