summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
commita7bc1588e6b8ad4a890d9cc884016f36f92f2e7d (patch)
tree284cc0af9edb74bfafad70b5a6fac9ad8b07b532 /gnu/packages/patches
parent8a502c3b60fdd5d8ee0b08e1c9d4c0d7fedc2fda (diff)
parentdf570bf271536399993b39e7ea2ea0452bb6cde4 (diff)
downloadguix-patches-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar
guix-patches-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mariadb-client-test-32bit.patch37
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch33
-rw-r--r--gnu/packages/patches/openblas-fix-tests-i686.patch35
-rw-r--r--gnu/packages/patches/pulseaudio-glibc-2.27.patch67
4 files changed, 54 insertions, 118 deletions
diff --git a/gnu/packages/patches/mariadb-client-test-32bit.patch b/gnu/packages/patches/mariadb-client-test-32bit.patch
new file mode 100644
index 0000000000..02017e324d
--- /dev/null
+++ b/gnu/packages/patches/mariadb-client-test-32bit.patch
@@ -0,0 +1,37 @@
+From 93efa48a7b972fc463406603574a4d508eefe792 Mon Sep 17 00:00:00 2001
+From: Sergei Golubchik <serg@mariadb.org>
+Date: Sun, 13 May 2018 18:50:21 +0200
+Subject: [PATCH] fix failing main.mysql_client_test test on 32bit
+
+in `ulonglong=ulong*uint` multiplication
+is done in ulong, wrapping around on 32bit.
+
+This became visible after C/C changed the
+default charset to utf8, thus changing
+mbmaxlem from 1 to 3.
+---
+ tests/mysql_client_fw.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/mysql_client_fw.c b/tests/mysql_client_fw.c
+index f69eb28a2871..4d036887629a 100644
+--- a/tests/mysql_client_fw.c
++++ b/tests/mysql_client_fw.c
+@@ -768,7 +768,7 @@ static void do_verify_prepare_field(MYSQL_RES *result,
+ {
+ MYSQL_FIELD *field;
+ CHARSET_INFO *cs;
+- ulonglong expected_field_length;
++ ulonglong expected_field_length= length;
+
+ if (!(field= mysql_fetch_field_direct(result, no)))
+ {
+@@ -777,7 +777,7 @@ static void do_verify_prepare_field(MYSQL_RES *result,
+ }
+ cs= get_charset(field->charsetnr, 0);
+ DIE_UNLESS(cs);
+- if ((expected_field_length= length * cs->mbmaxlen) > UINT_MAX32)
++ if ((expected_field_length*= cs->mbmaxlen) > UINT_MAX32)
+ expected_field_length= UINT_MAX32;
+ if (!opt_silent)
+ {
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
index 2151d53565..59249e294d 100644
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -4,20 +4,21 @@ meson-build-system.
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
---- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
-+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
-@@ -391,14 +391,6 @@
- print("Symlink creation does not work on this platform. "
- "Skipping all symlinking.")
- printed_symlink_error = True
-- if os.path.isfile(outname):
-- try:
-- depfixer.fix_rpath(outname, install_rpath, False)
-- except SystemExit as e:
-- if isinstance(e.code, int) and e.code == 0:
-- pass
-- else:
-- raise
-
+--- meson-0.42.0/mesonbuild/minstall.py.orig 2017-09-09 01:49:39.147374148 +0200
++++ meson-0.42.0/mesonbuild/minstall.py 2017-09-09 01:51:01.209134717 +0200
+@@ -436,15 +436,6 @@
+ print("Symlink creation does not work on this platform. "
+ "Skipping all symlinking.")
+ printed_symlink_error = True
+- if os.path.isfile(outname):
+- try:
+- depfixer.fix_rpath(outname, install_rpath, final_path,
+- install_name_mappings, verbose=False)
+- except SystemExit as e:
+- if isinstance(e.code, int) and e.code == 0:
+- pass
+- else:
+- raise
+
def run(args):
- global install_log_file
+ parser = buildparser()
diff --git a/gnu/packages/patches/openblas-fix-tests-i686.patch b/gnu/packages/patches/openblas-fix-tests-i686.patch
deleted file mode 100644
index 3325546ea3..0000000000
--- a/gnu/packages/patches/openblas-fix-tests-i686.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Fix a test failure on some i686 systems:
-
-https://github.com/xianyi/OpenBLAS/issues/1575
-
-This patch is a squashed version of these commits:
-
-https://github.com/xianyi/OpenBLAS/pull/1583
-
-diff --git a/kernel/x86/KERNEL.NEHALEM b/kernel/x86/KERNEL.NEHALEM
-index 835520ef..65b03ae5 100644
---- a/kernel/x86/KERNEL.NEHALEM
-+++ b/kernel/x86/KERNEL.NEHALEM
-@@ -1,3 +1 @@
- include $(KERNELDIR)/KERNEL.PENRYN
--SSWAPKERNEL = ../arm/swap.c
--DSWAPKERNEL = ../arm/swap.c
-diff --git a/kernel/x86/swap.S b/kernel/x86/swap.S
-index 54b00b33..e30c2789 100644
---- a/kernel/x86/swap.S
-+++ b/kernel/x86/swap.S
-@@ -138,6 +138,14 @@
- /* INCX != 1 or INCY != 1 */
-
- .L14:
-+ cmpl $0, %ebx
-+ jne .L141
-+ cmpl $0, %ecx
-+ jne .L141
-+/* INCX == 0 and INCY == 0 */
-+ jmp .L27
-+
-+.L141:
- movl %edx, %eax
- sarl $2, %eax
- jle .L28
diff --git a/gnu/packages/patches/pulseaudio-glibc-2.27.patch b/gnu/packages/patches/pulseaudio-glibc-2.27.patch
deleted file mode 100644
index 79d86abeee..0000000000
--- a/gnu/packages/patches/pulseaudio-glibc-2.27.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-Copied from:
-https://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/?id=dfb0460fb4743aec047cdf755a660a9ac2d0f3fb
-
-
-From dfb0460fb4743aec047cdf755a660a9ac2d0f3fb Mon Sep 17 00:00:00 2001
-From: Tanu Kaskinen <tanuk@iki.fi>
-Date: Wed, 24 Jan 2018 03:51:49 +0200
-Subject: [PATCH] memfd-wrappers: only define memfd_create() if not already
- defined
-
-glibc 2.27 is to be released soon, and it will provide memfd_create().
-If glibc provides the function, we must not define it ourselves,
-otherwise building fails due to conflict between the two implementations
-of the same function.
-
-BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=104733
----
- configure.ac | 3 +++
- src/pulsecore/memfd-wrappers.h | 7 ++++---
- 2 files changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 0084c86e..0eb44b08 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -610,6 +610,9 @@ AS_IF([test "x$enable_memfd" = "xyes" && test "x$HAVE_MEMFD" = "x0"],
- [AC_MSG_ERROR([*** Your Linux kernel does not support memfd shared memory.
- *** Use linux v3.17 or higher for such a feature.])])
-
-+AS_IF([test "x$HAVE_MEMFD" = "x1"],
-+ AC_CHECK_FUNCS([memfd_create]))
-+
- AC_SUBST(HAVE_MEMFD)
- AM_CONDITIONAL([HAVE_MEMFD], [test "x$HAVE_MEMFD" = x1])
- AS_IF([test "x$HAVE_MEMFD" = "x1"], AC_DEFINE([HAVE_MEMFD], 1, [Have memfd shared memory.]))
-diff --git a/src/pulsecore/memfd-wrappers.h b/src/pulsecore/memfd-wrappers.h
-index 3bed9b2b..c7aadfd3 100644
---- a/src/pulsecore/memfd-wrappers.h
-+++ b/src/pulsecore/memfd-wrappers.h
-@@ -20,13 +20,14 @@
- License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
- ***/
-
--#ifdef HAVE_MEMFD
-+#if defined(HAVE_MEMFD) && !defined(HAVE_MEMFD_CREATE)
-
- #include <sys/syscall.h>
- #include <fcntl.h>
-
- /*
-- * No glibc wrappers exist for memfd_create(2), so provide our own.
-+ * Before glibc version 2.27 there was no wrapper for memfd_create(2),
-+ * so we have to provide our own.
- *
- * Also define memfd fcntl sealing macros. While they are already
- * defined in the kernel header file <linux/fcntl.h>, that file as
-@@ -63,6 +64,6 @@ static inline int memfd_create(const char *name, unsigned int flags) {
- #define F_SEAL_WRITE 0x0008 /* prevent writes */
- #endif
-
--#endif /* HAVE_MEMFD */
-+#endif /* HAVE_MEMFD && !HAVE_MEMFD_CREATE */
-
- #endif
---
-2.16.2
-