summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-08-15 13:17:55 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-08-15 13:17:55 -0400
commit95b90decd3303d691b5c3d305f7cef0c7e60182d (patch)
tree26a8497c505e4201b9262a15573870c8f228c91f /gnu/packages/patches
parentd82a5e70c8c92ab0e26b8e45c5230698a0b45075 (diff)
downloadguix-patches-95b90decd3303d691b5c3d305f7cef0c7e60182d.tar
guix-patches-95b90decd3303d691b5c3d305f7cef0c7e60182d.tar.gz
gnu: gvfs: Fix build with libplist 2.2.0.
* gnu/packages/gnome.scm (gvfs)[source]: Add patch. * gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch b/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch
new file mode 100644
index 0000000000..250eef2c8b
--- /dev/null
+++ b/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch
@@ -0,0 +1,34 @@
+Source: https://gitlab.gnome.org/GNOME/gvfs/-/commit/13551f3f40d41f1357126ac5a26d0fa012cd8123
+
+Note: This change should be incorporated into stable version 1.46.x of gvfs.
+
+From 13551f3f40d41f1357126ac5a26d0fa012cd8123 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Tue, 16 Jun 2020 13:28:35 +0200
+Subject: [PATCH] afc: Add support for libplist-2.2
+
+Which changed name from libplist to libplist-2.0 to embed its API
+version number in the library name.
+---
+ meson.build | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 1750f65ca..187bfd55f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -357,7 +357,10 @@ config_h.set('HAVE_LOGIND', enable_logind)
+ enable_afc = get_option('afc')
+ if enable_afc
+ libimobiledevice_dep = dependency('libimobiledevice-1.0', version: '>= 1.2')
+- libplist_dep = dependency('libplist', version: '>= 0.15')
++ libplist_dep = dependency('libplist-2.0', required: false)
++ if not libplist_dep.found()
++ libplist_dep = dependency('libplist', version: '>= 0.15')
++ endif
+ endif
+
+ # *** Check if we should build with GOA volume monitor ***
+--
+GitLab
+