summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 12:00:29 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 12:00:29 +0200
commit933d2fe4cfb380f66af631a2203ec23c367e5b1a (patch)
treef10581ed0da1911eed9b02e69d999ba481d9d3c6 /gnu/packages/patches
parentf8835ff4b3dd59d59bf44838d05d3d60114d15d2 (diff)
parent998afc3608242b75051f43ece36d52474c51e285 (diff)
downloadguix-patches-933d2fe4cfb380f66af631a2203ec23c367e5b1a.tar
guix-patches-933d2fe4cfb380f66af631a2203ec23c367e5b1a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libextractor-ffmpeg-3.patch360
-rw-r--r--gnu/packages/patches/mc-fix-ncurses-build.patch37
-rw-r--r--gnu/packages/patches/openssl-c-rehash.patch17
-rw-r--r--gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch17
-rw-r--r--gnu/packages/patches/wicd-template-instantiation.patch29
-rw-r--r--gnu/packages/patches/wicd-wpa2-ttls.patch38
6 files changed, 398 insertions, 100 deletions
diff --git a/gnu/packages/patches/libextractor-ffmpeg-3.patch b/gnu/packages/patches/libextractor-ffmpeg-3.patch
new file mode 100644
index 0000000000..d0f83f624c
--- /dev/null
+++ b/gnu/packages/patches/libextractor-ffmpeg-3.patch
@@ -0,0 +1,360 @@
+Fix build with ffmpeg-3, based on upstream revisions r35548 and r35549 by LRN
+and r36975 by Christian Grothoff, and backported to libextractor-1.3 by
+Mark H Weaver <mhw@netris.org>
+
+--- libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c.orig 2013-12-21 11:04:41.000000000 -0500
++++ libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c 2016-04-04 23:38:46.429041081 -0400
+@@ -59,6 +59,12 @@
+ #include <ffmpeg/swscale.h>
+ #endif
+
++#ifdef PIX_FMT_RGB24
++#define PIX_OUTPUT_FORMAT PIX_FMT_RGB24
++#else
++#define PIX_OUTPUT_FORMAT AV_PIX_FMT_RGB24
++#endif
++
+ /**
+ * Set to 1 to enable debug output.
+ */
+@@ -153,7 +159,7 @@
+ static size_t
+ create_thumbnail (int src_width, int src_height,
+ int src_stride[],
+- enum PixelFormat src_pixfmt,
++ enum AVPixelFormat src_pixfmt,
+ const uint8_t * const src_data[],
+ int dst_width, int dst_height,
+ uint8_t **output_data,
+@@ -189,7 +195,8 @@
+ if (NULL ==
+ (scaler_ctx =
+ sws_getContext (src_width, src_height, src_pixfmt,
+- dst_width, dst_height, PIX_FMT_RGB24,
++ dst_width, dst_height,
++ PIX_OUTPUT_FORMAT,
+ SWS_BILINEAR, NULL, NULL, NULL)))
+ {
+ #if DEBUG
+@@ -199,7 +206,12 @@
+ return 0;
+ }
+
+- if (NULL == (dst_frame = avcodec_alloc_frame ()))
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ dst_frame = av_frame_alloc ();
++#else
++ dst_frame = avcodec_alloc_frame();
++#endif
++ if (NULL == dst_frame)
+ {
+ #if DEBUG
+ fprintf (stderr,
+@@ -209,18 +221,24 @@
+ return 0;
+ }
+ if (NULL == (dst_buffer =
+- av_malloc (avpicture_get_size (PIX_FMT_RGB24, dst_width, dst_height))))
++ av_malloc (avpicture_get_size (PIX_OUTPUT_FORMAT,
++ dst_width, dst_height))))
+ {
+ #if DEBUG
+ fprintf (stderr,
+ "Failed to allocate the destination image buffer\n");
+ #endif
+- av_free (dst_frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&dst_frame);
++#else
++ avcodec_free_frame (&dst_frame);
++#endif
+ sws_freeContext (scaler_ctx);
+ return 0;
+ }
+ avpicture_fill ((AVPicture *) dst_frame, dst_buffer,
+- PIX_FMT_RGB24, dst_width, dst_height);
++ PIX_OUTPUT_FORMAT,
++ dst_width, dst_height);
+ sws_scale (scaler_ctx,
+ src_data,
+ src_stride,
+@@ -236,7 +254,11 @@
+ "Failed to allocate the encoder output buffer\n");
+ #endif
+ av_free (dst_buffer);
+- av_free (dst_frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&dst_frame);
++#else
++ avcodec_free_frame (&dst_frame);
++#endif
+ sws_freeContext (scaler_ctx);
+ return 0;
+ }
+@@ -249,13 +271,17 @@
+ #endif
+ av_free (encoder_output_buffer);
+ av_free (dst_buffer);
+- av_free (dst_frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&dst_frame);
++#else
++ avcodec_free_frame (&dst_frame);
++#endif
+ sws_freeContext (scaler_ctx);
+ return 0;
+ }
+ encoder_codec_ctx->width = dst_width;
+ encoder_codec_ctx->height = dst_height;
+- encoder_codec_ctx->pix_fmt = PIX_FMT_RGB24;
++ encoder_codec_ctx->pix_fmt = PIX_OUTPUT_FORMAT;
+ opts = NULL;
+ if (avcodec_open2 (encoder_codec_ctx, encoder_codec, &opts) < 0)
+ {
+@@ -263,10 +289,14 @@
+ fprintf (stderr,
+ "Failed to open the encoder\n");
+ #endif
+- av_free (encoder_codec_ctx);
++ avcodec_free_context (&encoder_codec_ctx);
+ av_free (encoder_output_buffer);
+ av_free (dst_buffer);
+- av_free (dst_frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&dst_frame);
++#else
++ avcodec_free_frame (&dst_frame);
++#endif
+ sws_freeContext (scaler_ctx);
+ return 0;
+ }
+@@ -295,9 +325,13 @@
+ cleanup:
+ av_dict_free (&opts);
+ avcodec_close (encoder_codec_ctx);
+- av_free (encoder_codec_ctx);
++ avcodec_free_context (&encoder_codec_ctx);
+ av_free (dst_buffer);
+- av_free (dst_frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&dst_frame);
++#else
++ avcodec_free_frame (&dst_frame);
++#endif
+ sws_freeContext (scaler_ctx);
+ *output_data = encoder_output_buffer;
+
+@@ -406,18 +440,23 @@
+ fprintf (stderr,
+ "Failed to open image codec\n");
+ #endif
+- av_free (codec_ctx);
++ avcodec_free_context (&codec_ctx);
+ return;
+ }
+ av_dict_free (&opts);
+- if (NULL == (frame = avcodec_alloc_frame ()))
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ frame = av_frame_alloc ();
++#else
++ frame = avcodec_alloc_frame();
++#endif
++ if (NULL == frame)
+ {
+ #if DEBUG
+ fprintf (stderr,
+ "Failed to allocate frame\n");
+ #endif
+ avcodec_close (codec_ctx);
+- av_free (codec_ctx);
++ avcodec_free_context (&codec_ctx);
+ return;
+ }
+
+@@ -441,9 +480,13 @@
+ fprintf (stderr,
+ "Failed to decode a complete frame\n");
+ #endif
+- av_free (frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&frame);
++#else
++ avcodec_free_frame (&frame);
++#endif
+ avcodec_close (codec_ctx);
+- av_free (codec_ctx);
++ avcodec_free_context (&codec_ctx);
+ return;
+ }
+ calculate_thumbnail_dimensions (codec_ctx->width, codec_ctx->height,
+@@ -467,9 +510,13 @@
+ err);
+ av_free (encoded_thumbnail);
+ }
+- av_free (frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&frame);
++#else
++ avcodec_free_frame (&frame);
++#endif
+ avcodec_close (codec_ctx);
+- av_free (codec_ctx);
++ avcodec_free_context (&codec_ctx);
+ }
+
+
+@@ -563,7 +610,12 @@
+ return;
+ }
+
+- if (NULL == (frame = avcodec_alloc_frame ()))
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ frame = av_frame_alloc ();
++#else
++ frame = avcodec_alloc_frame();
++#endif
++ if (NULL == frame)
+ {
+ #if DEBUG
+ fprintf (stderr,
+@@ -616,7 +668,11 @@
+ fprintf (stderr,
+ "Failed to decode a complete frame\n");
+ #endif
+- av_free (frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&frame);
++#else
++ avcodec_free_frame (&frame);
++#endif
+ avcodec_close (codec_ctx);
+ avformat_close_input (&format_ctx);
+ av_free (io_ctx);
+@@ -643,7 +699,11 @@
+ err);
+ av_free (encoded_thumbnail);
+ }
+- av_free (frame);
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&frame);
++#else
++ avcodec_free_frame (&frame);
++#endif
+ avcodec_close (codec_ctx);
+ avformat_close_input (&format_ctx);
+ av_free (io_ctx);
+--- libextractor-1.3/src/plugins/previewopus_extractor.c.orig 2013-12-22 17:44:18.000000000 -0500
++++ libextractor-1.3/src/plugins/previewopus_extractor.c 2016-04-04 23:39:41.377720710 -0400
+@@ -296,8 +296,13 @@
+ /** Initialize one audio frame for reading from the input file */
+ static int init_input_frame(AVFrame **frame)
+ {
+- if (!(*frame = avcodec_alloc_frame())) {
+- #if DEBUG
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ *frame = av_frame_alloc ();
++#else
++ *frame = avcodec_alloc_frame();
++#endif
++ if (NULL == *frame) {
++#if DEBUG
+ fprintf(stderr, "Could not allocate input frame\n");
+ #endif
+ return AVERROR(ENOMEM);
+@@ -655,7 +660,11 @@
+ av_freep(&converted_input_samples[0]);
+ free(converted_input_samples);
+ }
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&input_frame);
++#else
+ avcodec_free_frame(&input_frame);
++#endif
+
+ return ret;
+ }
+@@ -671,10 +680,15 @@
+ int error;
+
+ /** Create a new frame to store the audio samples. */
+- if (!(*frame = avcodec_alloc_frame())) {
+- #if DEBUG
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ *frame = av_frame_alloc ();
++#else
++ *frame = avcodec_alloc_frame();
++#endif
++ if (NULL == *frame) {
++#if DEBUG
+ fprintf(stderr, "Could not allocate output frame\n");
+- #endif
++#endif
+ return AVERROR_EXIT;
+ }
+
+@@ -699,10 +713,14 @@
+ * sure that the audio frame can hold as many samples as specified.
+ */
+ if ((error = av_frame_get_buffer(*frame, 0)) < 0) {
+- #if DEBUG
++#if DEBUG
+ fprintf(stderr, "Could allocate output frame samples (error '%s')\n", get_error_text(error));
+- #endif
++#endif
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (frame);
++#else
+ avcodec_free_frame(frame);
++#endif
+ return error;
+ }
+
+@@ -780,20 +798,32 @@
+ * The samples are stored in the frame temporarily.
+ */
+ if (av_audio_fifo_read(fifo, (void **)output_frame->data, frame_size) < frame_size) {
+- #if DEBUG
++#if DEBUG
+ fprintf(stderr, "Could not read data from FIFO\n");
+- #endif
++#endif
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&output_frame);
++#else
+ avcodec_free_frame(&output_frame);
++#endif
+ return AVERROR_EXIT;
+ }
+
+ /** Encode one frame worth of audio samples. */
+ if (encode_audio_frame(output_frame, output_format_context,
+ output_codec_context, &data_written)) {
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&output_frame);
++#else
+ avcodec_free_frame(&output_frame);
++#endif
+ return AVERROR_EXIT;
+ }
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ av_frame_free (&output_frame);
++#else
+ avcodec_free_frame(&output_frame);
++#endif
+ return 0;
+ }
+ /** Write the trailer of the output file container. */
+@@ -907,7 +937,12 @@
+ return;
+ }
+
+- if (NULL == (frame = avcodec_alloc_frame ()))
++#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(55,28,1)
++ frame = av_frame_alloc ();
++#else
++ frame = avcodec_alloc_frame();
++#endif
++ if (NULL == frame)
+ {
+ #if DEBUG
+ fprintf (stderr,
diff --git a/gnu/packages/patches/mc-fix-ncurses-build.patch b/gnu/packages/patches/mc-fix-ncurses-build.patch
deleted file mode 100644
index c583c92e10..0000000000
--- a/gnu/packages/patches/mc-fix-ncurses-build.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Patch cherry-picked from resolution of
-http://www.midnight-commander.org/ticket/3114
-
---- a/lib/tty/key.c (revision 0ed4a91d7df4e50512defd2e0734ecab7c9da07f)
-+++ b/lib/tty/key.c (revision d870aedad1907773f8586fe818a89e6b5178b849)
-@@ -1947,4 +1947,5 @@
- {
- int c;
-+ int flag = 0; /* Return value from select */
- #ifdef HAVE_LIBGPM
- static struct Gpm_Event ev; /* Mouse event */
-@@ -1979,5 +1980,4 @@
- {
- int nfd;
-- static int flag = 0; /* Return value from select */
- fd_set select_set;
-
---- a/lib/tty/tty-ncurses.c (revision bb65b467900ea9eb1f7867c059fd26fac86c747c)
-+++ b/lib/tty/tty-ncurses.c (revision d870aedad1907773f8586fe818a89e6b5178b849)
-@@ -50,4 +50,5 @@
- #include "tty.h"
- #include "color-internal.h"
-+#include "key.h"
- #include "mouse.h"
- #include "win.h"
-@@ -531,4 +532,5 @@
- {
- int res;
-+ unsigned char str[UTF8_CHAR_LEN + 1];
-
- res = g_unichar_to_utf8 (c, (char *) str);
-@@ -541,5 +543,4 @@
- else
- {
-- unsigned char str[UTF8_CHAR_LEN + 1];
- const char *s;
-
diff --git a/gnu/packages/patches/openssl-c-rehash.patch b/gnu/packages/patches/openssl-c-rehash.patch
deleted file mode 100644
index f873a9af23..0000000000
--- a/gnu/packages/patches/openssl-c-rehash.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-This patch removes the explicit reference to the 'perl' binary,
-such that OpenSSL does not retain a reference to Perl.
-
-The 'c_rehash' program is seldom used, but it is used nonetheless
-to create symbolic links to certificates, for instance in the 'nss-certs'
-package.
-
---- openssl-1.0.2d/tools/c_rehash 2015-09-09 18:36:07.313316482 +0200
-+++ openssl-1.0.2d/tools/c_rehash 2015-09-09 18:36:28.965458458 +0200
-@@ -1,4 +1,6 @@
--#!/usr/bin/perl
-+eval '(exit $?0)' && eval 'exec perl -wS "$0" ${1+"$@"}'
-+ & eval 'exec perl -wS "$0" $argv:q'
-+ if 0;
-
- # Perl c_rehash script, scan all files in a directory
- # and add symbolic links to their hash values.
diff --git a/gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch b/gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch
deleted file mode 100644
index 671b5fb910..0000000000
--- a/gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Copied from Fedora.
-
-https://bugzilla.redhat.com/show_bug.cgi?id=1189303
-http://pkgs.fedoraproject.org/cgit/webkitgtk.git/commit/?id=e689e45d0cc2c50484e69d20371ba607af7326f3
-
-diff -up webkitgtk-2.4.9/Source/WebCore/platform/sql/SQLiteStatement.cpp.sql_initialize_string webkitgtk-2.4.9/Source/WebCore/platform/sql/SQLiteStatement.cpp
---- webkitgtk-2.4.9/Source/WebCore/platform/sql/SQLiteStatement.cpp.sql_initialize_string 2015-09-14 09:25:43.004200172 +0200
-+++ webkitgtk-2.4.9/Source/WebCore/platform/sql/SQLiteStatement.cpp 2015-09-14 09:25:57.852082368 +0200
-@@ -71,7 +71,7 @@ int SQLiteStatement::prepare()
- // this lets SQLite avoid an extra string copy.
- size_t lengthIncludingNullCharacter = query.length() + 1;
-
-- const char* tail;
-+ const char* tail = nullptr;
- int error = sqlite3_prepare_v2(m_database.sqlite3Handle(), query.data(), lengthIncludingNullCharacter, &m_statement, &tail);
-
- if (error != SQLITE_OK)
diff --git a/gnu/packages/patches/wicd-template-instantiation.patch b/gnu/packages/patches/wicd-template-instantiation.patch
deleted file mode 100644
index 16d8fa6e1d..0000000000
--- a/gnu/packages/patches/wicd-template-instantiation.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Wicd 1.7.3 fails to instantiate template lines that have several
-variable references. For instance, the line:
-
- wep_key$_KEY_INDEX=$_KEY
-
-which is found in in the 'wep-hex' template, expands to these two
-lines:
-
- wep_key0=$_KEY
- wep_key0=123456789ab
-
-This patch fixes that by only emitting the fully substituted line.
-
-Patch by Ludovic Courtès <ludo@gnu.org>.
-
---- a/wicd/misc.py 2012-11-17 00:07:08 +0000
-+++ b/wicd/misc.py 2015-05-09 11:22:37 +0000
-@@ -321,11 +321,11 @@ def ParseEncryption(network):
- rep_val = '0'
- if rep_val:
- line = line.replace("$_%s" % cur_val, str(rep_val))
-- config_file = ''.join([config_file, line])
- else:
- print "Ignoring template line: '%s'" % line
- else:
- print "Weird parsing error occurred"
-+ config_file = ''.join([config_file, line])
- else: # Just a regular entry.
- config_file = ''.join([config_file, line])
diff --git a/gnu/packages/patches/wicd-wpa2-ttls.patch b/gnu/packages/patches/wicd-wpa2-ttls.patch
new file mode 100644
index 0000000000..9d80ee7ed2
--- /dev/null
+++ b/gnu/packages/patches/wicd-wpa2-ttls.patch
@@ -0,0 +1,38 @@
+Add a template for WPA2-TTLS, which is notably used by Eduroam.
+
+--- a/encryption/templates/active
++++ b/encryption/templates/active
+@@ -4,6 +4,7 @@ wpa-psk
+ wpa-psk-hex
+ wpa2-leap
+ wpa2-peap
++wpa2-ttls
+ wep-hex
+ wep-passphrase
+ wep-shared
+diff --git a/encryption/templates/wpa2-ttls b/encryption/templates/wpa2-ttls
+new file mode 100644
+index 0000000..4f66a1e
+--- /dev/null
++++ b/encryption/templates/wpa2-ttls
+@@ -0,0 +1,20 @@
++name = WPA2-TTLS (used notably by Eduroam)
++author = various contributors
++version = 1
++require identity *Identity anonymous_identity *Anonymous_identity password *Password ca_cert *Path_to_CA_Cert
++protected password *Password
++-----
++ctrl_interface=/var/run/wpa_supplicant
++network={
++ ssid="$_ESSID"
++ scan_ssid=$_SCAN
++ proto=WPA2
++ key_mgmt=WPA-EAP
++ group=CCMP TKIP
++ eap=TTLS
++ identity="$_IDENTITY"
++ password="$_PASSWORD"
++ anonymous_identity="$_ANONYMOUS_IDENTITY"
++ ca_cert="$_CA_CERT"
++ phase2="auth=PAP"
++}