summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-06-16 13:51:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-06-16 23:18:26 +0300
commit8d5c55b2e8c56429f7a6713080c2e7bc4dafe983 (patch)
tree29a5ab1b6fbfe77f30a28502153c8330d13a91df /gnu/packages/patches
parentdaca70770ad074dacc14c83dd7156859d14286d3 (diff)
downloadguix-patches-8d5c55b2e8c56429f7a6713080c2e7bc4dafe983.tar
guix-patches-8d5c55b2e8c56429f7a6713080c2e7bc4dafe983.tar.gz
gnu: python-memcached: Add patch to fix syntax warnings.
* gnu/packages/patches/python-memcached-syntax-warnings.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-xyz.scm (python-memcached)[source]: Add it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-memcached-syntax-warnings.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-memcached-syntax-warnings.patch b/gnu/packages/patches/python-memcached-syntax-warnings.patch
new file mode 100644
index 0000000000..f8690677c0
--- /dev/null
+++ b/gnu/packages/patches/python-memcached-syntax-warnings.patch
@@ -0,0 +1,24 @@
+Problem reported upstream:
+https://github.com/linsomniac/python-memcached/issues/176
+
+---
+ memcache.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/memcache.py b/memcache.py
+index 05b6657..b935681 100644
+--- a/memcache.py
++++ b/memcache.py
+@@ -1300,8 +1300,8 @@ class Client(threading.local):
+ key = key[1]
+ if key is None:
+ raise Client.MemcachedKeyNoneError("Key is None")
+- if key is '':
+- if key_extra_len is 0:
++ if key == '':
++ if key_extra_len == 0:
+ raise Client.MemcachedKeyNoneError("Key is empty")
+
+ # key is empty but there is some other component to key
+--
+2.26.2