summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-13 14:52:08 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 15:34:02 +0200
commit84b238c8f23a9379fccdede66034836ef8a29e1d (patch)
treebb30b53c8fc6a553898a33c11cbc0f3fcbcec765 /gnu/packages/patches
parent3090e6104a2ee975bc4ddfc6422b60cc8b6bc3c4 (diff)
downloadguix-patches-84b238c8f23a9379fccdede66034836ef8a29e1d.tar
guix-patches-84b238c8f23a9379fccdede66034836ef8a29e1d.tar.gz
gnu: libcacard: Update to 2.8.0.
* gnu/packages/patches/libcacard-unknown-variable.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/spice.scm (libcacard): Update to 2.8.0. [source](patches): New field. [arguments]: Remove trailing #t.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libcacard-unknown-variable.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/libcacard-unknown-variable.patch b/gnu/packages/patches/libcacard-unknown-variable.patch
new file mode 100644
index 0000000000..830a3ee8c0
--- /dev/null
+++ b/gnu/packages/patches/libcacard-unknown-variable.patch
@@ -0,0 +1,50 @@
+Fix Meson error when test dependencies are missing.
+
+Based on this upstream commit, with some adjustments to apply on 2.8.0:
+https://gitlab.freedesktop.org/spice/libcacard/-/commit/cf6121deb47e437aa566cfeb29a03da93c432394
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 87945a2..baefaf5 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -9,15 +9,6 @@ modutil_dep = find_program('modutil', required: false)
+ openssl_dep = find_program('openssl', required: false)
+ softhsm_util_dep = find_program('softhsm2-util', required: false)
+
+-if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
+- softhsm = custom_target(
+- 'softhsm2.conf',
+- command: find_program('setup-softhsm2.sh'),
+- capture: true,
+- output: 'setup-softhsm2.log',
+- )
+-endif
+-
+ libcacard_test = executable(
+ 'libcacard',
+ ['libcacard.c', 'common.c'],
+@@ -64,9 +55,18 @@ hwtests_test = executable(
+ dependencies: [libcacard_dep],
+ )
+
+-test(
+- 'hwtests',
+- hwtests_test,
+- depends: [softhsm],
+- env: env,
+-)
++if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
++ softhsm = custom_target(
++ 'softhsm2.conf',
++ command: find_program('setup-softhsm2.sh'),
++ capture: true,
++ output: 'setup-softhsm2.log',
++ )
++
++ test(
++ 'hwtests',
++ hwtests_test,
++ depends: [softhsm],
++ env: env,
++ )
++endif