summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-11-03 15:22:19 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-08 13:34:01 +0100
commit7fbb6fe0e1035e2a09fe9ffcd5b91c1586510f99 (patch)
tree86c9089620fd2076c8e2b072d66f58e9c7470def /gnu/packages/patches
parent4469990f2e4b300781c93dfd41a82c41611842e3 (diff)
downloadguix-patches-7fbb6fe0e1035e2a09fe9ffcd5b91c1586510f99.tar
guix-patches-7fbb6fe0e1035e2a09fe9ffcd5b91c1586510f99.tar.gz
gnu: Add bloomberg-bde.
* gnu/packages/cpp.scm (bloomberg-bde): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bloomberg-bde-cmake-module-path.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
new file mode 100644
index 0000000000..b08ca5eac0
--- /dev/null
+++ b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
@@ -0,0 +1,16 @@
+This package requires CMAKE_MODULE_PATH be set by the calling process. This
+patch uses the CMAKE_PREFIX_PATH passed from Guix as the search path for
+locating the bloomberg-bde-tools CMake modules.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,8 +1,6 @@
+ cmake_minimum_required(VERSION 3.15)
+
+-if (NOT CMAKE_MODULE_PATH)
+- message(FATAL "Please specify path to BDE cmake modules.")
+-endif()
++string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
+
+ get_filename_component(repoName ${CMAKE_CURRENT_LIST_DIR} NAME)
+