summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-22 22:58:31 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-02 23:33:42 -0400
commit7bf82f5ede57c9c5344ddb1d4dcfe694eb306bef (patch)
treee472bea91e3682553f2d3210c5ecb636677c08cf /gnu/packages/patches
parent8d89d3c9bf7cacd9c79b4aacf348044d4fe7800b (diff)
downloadguix-patches-7bf82f5ede57c9c5344ddb1d4dcfe694eb306bef.tar
guix-patches-7bf82f5ede57c9c5344ddb1d4dcfe694eb306bef.tar.gz
gnu: containerd: Update to 1.4.4.
* gnu/packages/docker.scm (containerd): Update to 1.4.4. Delete trailing #t. [arguments]: Set a MAKE-FLAGS binding. [phases]{patch-paths}: Patch the reference to 'unpigz'. {build, install}: Use the MAKE-FLAGS variable. [inputs]: Add pigz. * gnu/packages/patches/containerd-test-with-go1.13.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Un-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/containerd-test-with-go1.13.patch21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/patches/containerd-test-with-go1.13.patch b/gnu/packages/patches/containerd-test-with-go1.13.patch
deleted file mode 100644
index 964adee9e6..0000000000
--- a/gnu/packages/patches/containerd-test-with-go1.13.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Compatibility fix for go 1.13, flag.Parse() shouldn't be called during
-package initialization.
-https://golang.org/doc/go1.13#testing
---- a/client_test.go 2020-02-12 14:50:28.991245371 -0500
-+++ b/client_test.go 2020-02-12 15:12:37.383523980 -0500
-@@ -49,7 +49,6 @@
- flag.StringVar(&address, "address", defaultAddress, "The address to the containerd socket for use in the tests")
- flag.BoolVar(&noDaemon, "no-daemon", false, "Do not start a dedicated daemon for the tests")
- flag.BoolVar(&noCriu, "no-criu", false, "Do not run the checkpoint tests")
-- flag.Parse()
- }
-
- func testContext() (context.Context, context.CancelFunc) {
-@@ -59,6 +58,7 @@
- }
-
- func TestMain(m *testing.M) {
-+ flag.Parse()
- if testing.Short() {
- os.Exit(m.Run())
- }