summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-02-01 20:00:31 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-02-01 20:06:25 +0100
commit787b13a5d9df8f0cc7170de1b80cead68b516c66 (patch)
tree1399b14d16ea0ebacbfd587bfc07c7cb0529ee71 /gnu/packages/patches
parentf07459ea05c06b8bc7dff92285e652d2449dd45b (diff)
downloadguix-patches-787b13a5d9df8f0cc7170de1b80cead68b516c66.tar
guix-patches-787b13a5d9df8f0cc7170de1b80cead68b516c66.tar.gz
gnu: librecad: Fix build with boost 1.76.
Fixes <https://issues.guix.gnu.org/53694>. * gnu/packages/patches/librecad-support-for-boost-1.76.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (librecad)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/librecad-support-for-boost-1.76.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/librecad-support-for-boost-1.76.patch b/gnu/packages/patches/librecad-support-for-boost-1.76.patch
new file mode 100644
index 0000000000..aa352e669f
--- /dev/null
+++ b/gnu/packages/patches/librecad-support-for-boost-1.76.patch
@@ -0,0 +1,17 @@
+Upstream commit e02f3580311d50b617427652ff77988f6bd62d9d adding Boost 1.76
+compatibility.
+
+diff --git a/librecad/src/lib/engine/rs_ellipse.cpp b/librecad/src/lib/engine/rs_ellipse.cpp
+index 291f734ea..d47bf6ca4 100644
+--- a/librecad/src/lib/engine/rs_ellipse.cpp
++++ b/librecad/src/lib/engine/rs_ellipse.cpp
+@@ -48,6 +48,9 @@
+ #include <boost/version.hpp>
+ #include <boost/math/tools/roots.hpp>
+ #include <boost/math/special_functions/ellint_2.hpp>
++#if BOOST_VERSION > 104500
++#include <boost/math/tools/tuple.hpp>
++#endif
+ #endif
+
+ namespace{