summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:51:36 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit748e2ec07a4f484dd4416b4cac5c28b1b13c47ee (patch)
tree3c4f204faf3c0b07a3c4399ba4ee085bbdd99c90 /gnu/packages/patches
parentcc95d03ec7aa2d4de2f880fdb0c9ccbf3343e041 (diff)
downloadguix-patches-748e2ec07a4f484dd4416b4cac5c28b1b13c47ee.tar
guix-patches-748e2ec07a4f484dd4416b4cac5c28b1b13c47ee.tar.gz
gnu: Add aws-c-cal.
* gnu/packages/c.scm (aws-c-cal): New variable. * gnu/packages/patches/aws-c-cal-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/aws-c-cal-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-cal-cmake-prefix.patch b/gnu/packages/patches/aws-c-cal-cmake-prefix.patch
new file mode 100644
index 0000000000..1ee7aa851d
--- /dev/null
+++ b/gnu/packages/patches/aws-c-cal-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -10,6 +10,10 @@ endif()
+
+ option(BYO_CRYPTO "Set this if you want to provide your own cryptography implementation. This will cause the defaults to not be compiled." OFF)
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()