summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-06-10 21:28:53 -0400
committerLeo Famulari <leo@famulari.name>2020-07-15 15:38:03 -0400
commit7233b19fde688d79d19ed1614a804c1d80f55260 (patch)
tree361e03a5ca66c4aed07eebc94de09566d4f58e87 /gnu/packages/patches
parent37fea3c30a79d2c401dd64b446a0fbfe4a14b966 (diff)
downloadguix-patches-7233b19fde688d79d19ed1614a804c1d80f55260.tar
guix-patches-7233b19fde688d79d19ed1614a804c1d80f55260.tar.gz
gnu: Transmission: Update to 3.0.0.
* gnu/packages/bittorrent.scm (transmission): Update to 3.0.0. [source]: Remove obsolete patch. * gnu/packages/patches/transmission-CVE-2018-10756.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/transmission-CVE-2018-10756.patch71
1 files changed, 0 insertions, 71 deletions
diff --git a/gnu/packages/patches/transmission-CVE-2018-10756.patch b/gnu/packages/patches/transmission-CVE-2018-10756.patch
deleted file mode 100644
index f9bdcf60aa..0000000000
--- a/gnu/packages/patches/transmission-CVE-2018-10756.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Fix CVE-2018-10756:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10756
-
-Patch copied from Fedora:
-
-https://src.fedoraproject.org/rpms/transmission/blob/master/f/2123adf8e5e1c2b48791f9d22fc8c747e974180e.patch
-
---- a/libtransmission/variant.c 2018-05-01 12:21:08.000000000 -0500
-+++ b/libtransmission/variant.c 2020-05-18 10:21:27.554214128 -0500
-@@ -820,7 +820,7 @@
- struct SaveNode
- {
- const tr_variant * v;
-- tr_variant sorted;
-+ tr_variant* sorted;
- size_t childIndex;
- bool isVisited;
- };
-@@ -849,26 +849,33 @@
-
- qsort (tmp, n, sizeof (struct KeyIndex), compareKeyIndex);
-
-- tr_variantInitDict (&node->sorted, n);
-+ node->sorted = tr_new(tr_variant, 1);
-+ tr_variantInitDict (node->sorted, n);
- for (i=0; i<n; ++i)
-- node->sorted.val.l.vals[i] = *tmp[i].val;
-+ node->sorted->val.l.vals[i] = *tmp[i].val;
- node->sorted.val.l.count = n;
-
- tr_free (tmp);
-
-- node->v = &node->sorted;
-+ v = node->sorted;
- }
- else
- {
-- node->v = v;
-+ node->sorted = NULL;
- }
-+
-+ node->v = v;
- }
-
- static void
- nodeDestruct (struct SaveNode * node)
- {
-- if (node->v == &node->sorted)
-- tr_free (node->sorted.val.l.vals);
-+ //TR_ASSERT(node != NULL);
-+ if (node->sorted != NULL)
-+ {
-+ tr_free(node->sorted->val.l.vals);
-+ tr_free(node->sorted);
-+ }
- }
-
- /**
---- a/libtransmission/variant.c 2020-05-18 10:21:49.000000000 -0500
-+++ b/libtransmission/variant.c 2020-05-18 10:24:34.673648865 -0500
-@@ -853,7 +853,7 @@
- tr_variantInitDict (node->sorted, n);
- for (i=0; i<n; ++i)
- node->sorted->val.l.vals[i] = *tmp[i].val;
-- node->sorted.val.l.count = n;
-+ node->sorted->val.l.count = n;
-
- tr_free (tmp);
-
-