summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 21:34:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 21:34:41 +0100
commit715110a8a2e9e4b1a89635950744eb5260b8ee7f (patch)
tree0d0e4c41631092a068d8b0823f4d6b0a8d725eed /gnu/packages/patches
parentb3c2ebda5bcedcfb88475e53b7f36c3a42cac8b4 (diff)
parent79e074ea10875ff75ca613179c70de12d64b19f5 (diff)
downloadguix-patches-715110a8a2e9e4b1a89635950744eb5260b8ee7f.tar
guix-patches-715110a8a2e9e4b1a89635950744eb5260b8ee7f.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gzdoom-find-system-libgme.patch21
-rw-r--r--gnu/packages/patches/python-packaging-test-arch.patch65
-rw-r--r--gnu/packages/patches/python2-parameterized-docstring-test.patch18
-rw-r--r--gnu/packages/patches/red-eclipse-remove-gamma-name-hack.patch52
-rw-r--r--gnu/packages/patches/spice-fix-test-armhf.patch19
-rw-r--r--gnu/packages/patches/supercollider-boost-1.70-build-fix.patch28
-rw-r--r--gnu/packages/patches/teeworlds-use-latest-wavpack.patch126
-rw-r--r--gnu/packages/patches/usb-modeswitch-accept-config-arg.patch42
-rw-r--r--gnu/packages/patches/xmoto-remove-glext.patch23
-rw-r--r--gnu/packages/patches/xmoto-reproducible.patch24
-rw-r--r--gnu/packages/patches/xmoto-utf8.patch16
11 files changed, 186 insertions, 248 deletions
diff --git a/gnu/packages/patches/gzdoom-find-system-libgme.patch b/gnu/packages/patches/gzdoom-find-system-libgme.patch
new file mode 100644
index 0000000000..a7f277d614
--- /dev/null
+++ b/gnu/packages/patches/gzdoom-find-system-libgme.patch
@@ -0,0 +1,21 @@
+--- /CMakeLists.txt 2020-01-20 21:47:35.460119141 +0100
++++ /CMakeLists.txt 2020-01-20 21:47:47.690112400 +0100
+@@ -195,12 +195,12 @@
+ #endif()
+
+ # GME
+-#find_path( GME_INCLUDE_DIR gme/gme.h )
+-#find_library( GME_LIBRARIES gme )
+-#mark_as_advanced( GME_INCLUDE_DIR GME_LIBRARIES )
+-#FIND_PACKAGE_HANDLE_STANDARD_ARGS( GME
+-# REQUIRED_VARS GME_LIBRARIES GME_INCLUDE_DIR
+-#)
++find_path( GME_INCLUDE_DIR gme/gme.h )
++find_library( GME_LIBRARIES gme )
++mark_as_advanced( GME_INCLUDE_DIR GME_LIBRARIES )
++FIND_PACKAGE_HANDLE_STANDARD_ARGS( GME
++ REQUIRED_VARS GME_LIBRARIES GME_INCLUDE_DIR
++)
+
+ if( MSVC )
+ # Eliminate unreferenced functions and data
diff --git a/gnu/packages/patches/python-packaging-test-arch.patch b/gnu/packages/patches/python-packaging-test-arch.patch
new file mode 100644
index 0000000000..df80a62544
--- /dev/null
+++ b/gnu/packages/patches/python-packaging-test-arch.patch
@@ -0,0 +1,65 @@
+Fix tests that are "hard coded" to expect x86_64 output by mocking the platform interface.
+
+Submitted upstream:
+https://github.com/pypa/packaging/pull/176
+
+diff --git a/tests/test_tags.py b/tests/test_tags.py
+index 1eacf68..0a3f1b4 100644
+--- a/tests/test_tags.py
++++ b/tests/test_tags.py
+@@ -435,37 +435,43 @@ class TestManylinuxPlatform:
+ linux_platform = list(tags._linux_platforms(is_32bit=False))
+ assert linux_platform == ["linux_x86_64"]
+
+- def test_linux_platforms_manylinux1(self, monkeypatch):
++ def test_linux_platforms_manylinux1(self, is_x86, monkeypatch):
+ monkeypatch.setattr(
+ tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux1"
+ )
+- if platform.system() != "Linux":
++ if platform.system() != "Linux" or not is_x86:
+ monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
++ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
+ platforms = list(tags._linux_platforms(is_32bit=False))
+- assert platforms == ["manylinux1_x86_64", "linux_x86_64"]
++ arch = platform.machine()
++ assert platforms == ["manylinux1_" + arch, "linux_" + arch]
+
+- def test_linux_platforms_manylinux2010(self, monkeypatch):
++ def test_linux_platforms_manylinux2010(self, is_x86, monkeypatch):
+ monkeypatch.setattr(
+ tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2010"
+ )
+- if platform.system() != "Linux":
++ if platform.system() != "Linux" or not is_x86:
+ monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
++ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
+ platforms = list(tags._linux_platforms(is_32bit=False))
+- expected = ["manylinux2010_x86_64", "manylinux1_x86_64", "linux_x86_64"]
++ arch = platform.machine()
++ expected = ["manylinux2010_" + arch, "manylinux1_" + arch, "linux_" + arch]
+ assert platforms == expected
+
+- def test_linux_platforms_manylinux2014(self, monkeypatch):
++ def test_linux_platforms_manylinux2014(self, is_x86, monkeypatch):
+ monkeypatch.setattr(
+ tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2014"
+ )
+- if platform.system() != "Linux":
++ if platform.system() != "Linux" or not is_x86:
+ monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
++ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
+ platforms = list(tags._linux_platforms(is_32bit=False))
++ arch = platform.machine()
+ expected = [
+- "manylinux2014_x86_64",
+- "manylinux2010_x86_64",
+- "manylinux1_x86_64",
+- "linux_x86_64",
++ "manylinux2014_" + arch,
++ "manylinux2010_" + arch,
++ "manylinux1_" + arch,
++ "linux_" + arch,
+ ]
+ assert platforms == expected
+
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
new file mode 100644
index 0000000000..14691e1904
--- /dev/null
+++ b/gnu/packages/patches/python2-parameterized-docstring-test.patch
@@ -0,0 +1,18 @@
+Skip unicode docstring test, required when running on Python 2.
+
+See <https://github.com/wolever/parameterized/issues/44>.
+
+--- a/parameterized/test.py
++++ b/parameterized/test.py
+@@ -284,11 +284,6 @@
+ " More" %(foo, )
+ )
+
+- @parameterized.expand([param("foo")])
+- def test_unicode_docstring(self, foo):
+- u"""Döcumentation."""
+- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
+-
+ @parameterized.expand([param("foo", )])
+ def test_default_values_get_correct_value(self, foo, bar=12):
+ """Documentation"""
diff --git a/gnu/packages/patches/red-eclipse-remove-gamma-name-hack.patch b/gnu/packages/patches/red-eclipse-remove-gamma-name-hack.patch
deleted file mode 100644
index 573920cb99..0000000000
--- a/gnu/packages/patches/red-eclipse-remove-gamma-name-hack.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From b16b4963c1ad81bb9ef784bc4913a4c8ab5f1bb4 Mon Sep 17 00:00:00 2001
-From: Lee Salzman <lsalzman@gmail.com>
-Date: Tue, 12 Sep 2017 14:45:10 -0400
-Subject: [PATCH] remove gamma name hack
-
----
- src/engine/main.cpp | 6 +++---
- src/shared/cube.h | 8 --------
- 2 files changed, 3 insertions(+), 11 deletions(-)
-
-diff --git a/src/engine/main.cpp b/src/engine/main.cpp
-index 1032004d..77c9233a 100644
---- a/src/engine/main.cpp
-+++ b/src/engine/main.cpp
-@@ -278,10 +278,10 @@ static void setgamma(int val)
- }
-
- static int curgamma = 100;
--VARF(IDF_PERSIST, gamma, 30, 100, 300,
-+VARFN(IDF_PERSIST, gamma, reqgamma, 30, 100, 300,
- {
-- if(initing || gamma == curgamma) return;
-- curgamma = gamma;
-+ if(initing || reqgamma == curgamma) return;
-+ curgamma = reqgamma;
- setgamma(curgamma);
- });
-
-diff --git a/src/shared/cube.h b/src/shared/cube.h
-index 3864c492..7ff5e267 100644
---- a/src/shared/cube.h
-+++ b/src/shared/cube.h
-@@ -3,19 +3,11 @@
-
- #define _FILE_OFFSET_BITS 64
-
--#ifdef __GNUC__
--#define gamma __gamma
--#endif
--
- #ifdef WIN32
- #define _USE_MATH_DEFINES
- #endif
- #include <math.h>
-
--#ifdef __GNUC__
--#undef gamma
--#endif
--
- #include <string.h>
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/gnu/packages/patches/spice-fix-test-armhf.patch b/gnu/packages/patches/spice-fix-test-armhf.patch
new file mode 100644
index 0000000000..5c51bd6ede
--- /dev/null
+++ b/gnu/packages/patches/spice-fix-test-armhf.patch
@@ -0,0 +1,19 @@
+Fix test failure on armhf and ppc64el:
+https://gitlab.freedesktop.org/spice/spice-server/issues/31
+
+Taken from upstream:
+https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
+
+diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
+index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
+--- a/server/tests/test-qxl-parsing.c
++++ b/server/tests/test-qxl-parsing.c
+@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
+ RedMemSlotInfo mem_info;
+ init_meminfo(&mem_info);
+
+- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
++ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
+ }
+
+ static void test_memslot_invalid_addresses(void)
diff --git a/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch b/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
deleted file mode 100644
index 073044fccb..0000000000
--- a/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Patches taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/supercollider/files/supercollider-3.10.2-boost-1.70.patch?id=a420618dc766bba0654dbe0ef67008fdc5e901c6 to fix supercollider build with boost 1.70.
-
-diff --git a/server/supernova/sc/sc_osc_handler.cpp b/server/supernova/sc/sc_osc_handler.cpp
-index 5116a1be87..96e937ec25 100644
---- a/server/supernova/sc/sc_osc_handler.cpp
-+++ b/server/supernova/sc/sc_osc_handler.cpp
-@@ -728,7 +728,8 @@ void sc_osc_handler::tcp_connection::handle_message() {
-
-
- void sc_osc_handler::start_tcp_accept(void) {
-- tcp_connection::pointer new_connection = tcp_connection::create(tcp_acceptor_.get_io_service());
-+ tcp_connection::pointer new_connection =
-+ tcp_connection::create((boost::asio::io_context&)tcp_acceptor_.get_executor().context());
-
- tcp_acceptor_.async_accept(
- new_connection->socket(),
-diff --git a/server/supernova/utilities/utils.hpp b/server/supernova/utilities/utils.hpp
-index 35b8ab5ad..a7c191f2d 100644
---- a/server/supernova/utilities/utils.hpp
-+++ b/server/supernova/utilities/utils.hpp
-@@ -23,6 +23,7 @@
-
- #include <type_traits>
-
-+#include <boost/checked_delete.hpp>
- #include <boost/intrusive_ptr.hpp>
- #include <boost/noncopyable.hpp>
- #include <boost/detail/atomic_count.hpp>
diff --git a/gnu/packages/patches/teeworlds-use-latest-wavpack.patch b/gnu/packages/patches/teeworlds-use-latest-wavpack.patch
deleted file mode 100644
index 3ad1340d2e..0000000000
--- a/gnu/packages/patches/teeworlds-use-latest-wavpack.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-Downloaded from https://salsa.debian.org/games-team/teeworlds/raw/master/debian/patches/new-wavpack.patch.
-
-From: Markus Koschany <apo@debian.org>
-Date: Thu, 25 Oct 2018 20:52:27 +0200
-Subject: new-wavpack
-
-Make wavpack compatible with Debian's version.
----
- src/engine/client/sound.cpp | 33 +++++++++++++++------------------
- src/engine/client/sound.h | 4 ----
- 2 files changed, 15 insertions(+), 22 deletions(-)
-
-diff --git a/src/engine/client/sound.cpp b/src/engine/client/sound.cpp
-index 048ec24..80de3c5 100644
---- a/src/engine/client/sound.cpp
-+++ b/src/engine/client/sound.cpp
-@@ -325,10 +325,6 @@ void CSound::RateConvert(int SampleID)
- pSample->m_NumFrames = NumFrames;
- }
-
--int CSound::ReadData(void *pBuffer, int Size)
--{
-- return io_read(ms_File, pBuffer, Size);
--}
-
- ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- {
-@@ -336,6 +332,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- int SampleID = -1;
- char aError[100];
- WavpackContext *pContext;
-+ char aWholePath[1024];
-+ IOHANDLE File;
-
- // don't waste memory on sound when we are stress testing
- if(g_Config.m_DbgStress)
-@@ -349,25 +347,29 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- return CSampleHandle();
-
- lock_wait(m_SoundLock);
-- ms_File = m_pStorage->OpenFile(pFilename, IOFLAG_READ, IStorage::TYPE_ALL);
-- if(!ms_File)
-+ File = m_pStorage->OpenFile(pFilename, IOFLAG_READ, IStorage::TYPE_ALL, aWholePath, sizeof(aWholePath));
-+ if(!File)
- {
- dbg_msg("sound/wv", "failed to open file. filename='%s'", pFilename);
- lock_unlock(m_SoundLock);
- return CSampleHandle();
- }
-+ else
-+ {
-+ io_close(File);
-+ }
-
- SampleID = AllocID();
- if(SampleID < 0)
- {
-- io_close(ms_File);
-- ms_File = 0;
-+ io_close(File);
-+ File = 0;
- lock_unlock(m_SoundLock);
- return CSampleHandle();
- }
- pSample = &m_aSamples[SampleID];
-
-- pContext = WavpackOpenFileInput(ReadData, aError);
-+ pContext = WavpackOpenFileInput(aWholePath, aError, OPEN_2CH_MAX, 0);
- if (pContext)
- {
- int m_aSamples = WavpackGetNumSamples(pContext);
-@@ -385,8 +387,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- if(pSample->m_Channels > 2)
- {
- dbg_msg("sound/wv", "file is not mono or stereo. filename='%s'", pFilename);
-- io_close(ms_File);
-- ms_File = 0;
-+ io_close(File);
-+ File = 0;
- lock_unlock(m_SoundLock);
- return CSampleHandle();
- }
-@@ -401,8 +403,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- if(BitsPerSample != 16)
- {
- dbg_msg("sound/wv", "bps is %d, not 16, filname='%s'", BitsPerSample, pFilename);
-- io_close(ms_File);
-- ms_File = 0;
-+ io_close(File);
-+ File = 0;
- lock_unlock(m_SoundLock);
- return CSampleHandle();
- }
-@@ -429,9 +431,6 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
- dbg_msg("sound/wv", "failed to open %s: %s", pFilename, aError);
- }
-
-- io_close(ms_File);
-- ms_File = NULL;
--
- if(g_Config.m_Debug)
- dbg_msg("sound/wv", "loaded %s", pFilename);
-
-@@ -560,7 +559,5 @@ bool CSound::IsPlaying(CSampleHandle SampleID)
- return Ret;
- }
-
--IOHANDLE CSound::ms_File = 0;
--
- IEngineSound *CreateEngineSound() { return new CSound; }
-
-diff --git a/src/engine/client/sound.h b/src/engine/client/sound.h
-index ff357c0..cec2cde 100644
---- a/src/engine/client/sound.h
-+++ b/src/engine/client/sound.h
-@@ -21,10 +21,6 @@ public:
-
- static void RateConvert(int SampleID);
-
-- // TODO: Refactor: clean this mess up
-- static IOHANDLE ms_File;
-- static int ReadData(void *pBuffer, int Size);
--
- virtual bool IsSoundEnabled() { return m_SoundEnabled != 0; }
-
- virtual CSampleHandle LoadWV(const char *pFilename);
diff --git a/gnu/packages/patches/usb-modeswitch-accept-config-arg.patch b/gnu/packages/patches/usb-modeswitch-accept-config-arg.patch
deleted file mode 100644
index 9c050f7ee6..0000000000
--- a/gnu/packages/patches/usb-modeswitch-accept-config-arg.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- old/usb_modeswitch.tcl 1970-01-01 01:00:00.000000000 +0100
-+++ usb_modeswitch.tcl 2019-06-12 08:39:42.140000000 +0200
-@@ -41,7 +41,7 @@
- global scsi usb config match device flags setup devdir loginit
-
- set flags(config) ""
--Log "[ParseGlobalConfig]"
-+Log "[ParseGlobalConfig $argv]"
-
- if {$flags(stordelay) > 0} {
- SetStorageDelay $flags(stordelay)
-@@ -496,9 +496,21 @@
- # end of proc {MatchDevice}
-
-
--proc {ParseGlobalConfig} {} {
-+proc {ParseGlobalConfig} {argv} {
-
- global flags
-+
-+set configFileParam ""
-+for {set i 0} {$i < [llength $argv]} {incr i} {
-+ switch -glob -- [set v [lindex $argv $i]] {
-+ --config-file=* {
-+ set configFileParam $v
-+ }
-+ }
-+}
-+if {$configFileParam != ""} {
-+ set configFile [string range $configFileParam [string length "--config-file="] end]
-+} else {
- set configFile ""
- set places [list /etc/usb_modeswitch.conf /etc/sysconfig/usb_modeswitch /etc/default/usb_modeswitch]
- foreach cfg $places {
-@@ -507,6 +519,7 @@
- break
- }
- }
-+}
- if {$configFile == ""} {return}
-
- set rc [open $configFile r]
diff --git a/gnu/packages/patches/xmoto-remove-glext.patch b/gnu/packages/patches/xmoto-remove-glext.patch
new file mode 100644
index 0000000000..ad0c848d1d
--- /dev/null
+++ b/gnu/packages/patches/xmoto-remove-glext.patch
@@ -0,0 +1,23 @@
+Description: Allow building without upstream-supplied glext.h
+Author: Stephen Kitt <steve@sk2.org>
+Bug: http://todo.xmoto.tuxfamily.org/index.php?do=details&task_id=803
+
+--- xmoto-0.5.9+dfsg.orig/src/include/xm_OpenGL.h
++++ xmoto-0.5.9+dfsg/src/include/xm_OpenGL.h
+@@ -1,7 +1,6 @@
+ #ifdef ENABLE_OPENGL
+ /* Pull in OpenGL headers */
+ /* following scissored from SDL_opengl.h */
+-#define __glext_h_ /* Don't let gl.h include glext.h */
+ #ifdef HAVE_APPLE_OPENGL_FRAMEWORK
+ #include <OpenGL/gl.h> /* Header File For The OpenGL Library */
+ #include <OpenGL/glu.h> /* Header File For The GLU Library */
+@@ -12,8 +11,5 @@
+ #include <GL/gl.h> /* Header File For The OpenGL Library */
+ #include <GL/glu.h> /* Header File For The GLU Library */
+ #endif
+-#undef __glext_h_
+-
+-#include "../glext.h"
+
+ #endif
diff --git a/gnu/packages/patches/xmoto-reproducible.patch b/gnu/packages/patches/xmoto-reproducible.patch
new file mode 100644
index 0000000000..606f4ec714
--- /dev/null
+++ b/gnu/packages/patches/xmoto-reproducible.patch
@@ -0,0 +1,24 @@
+Description: Avoid __DATE__ and __TIME__ to build reproducibly
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/src/GameInit.cpp
++++ b/src/GameInit.cpp
+@@ -248,7 +248,6 @@
+ Logger::setActiv(XMSession::instance()->noLog() == false); /* apply log activ mode */
+
+ LogInfo(std::string("X-Moto " + XMBuild::getVersionString(true)).c_str());
+- LogInfo("compiled at "__DATE__" "__TIME__);
+ if(SwapEndian::bigendien) {
+ LogInfo("Systeme is bigendien");
+ } else {
+--- a/src/states/StateOptions.cpp
++++ b/src/states/StateOptions.cpp
+@@ -1233,8 +1233,6 @@
+ int p=25;
+ makeWindowOptions_infos_line(v_window, "Version", "X-Moto " + XMBuild::getVersionString(true), p);
+ p+=20;
+- makeWindowOptions_infos_line(v_window, "Compilation date", __DATE__ " " __TIME__, p);
+- p+=20;
+ makeWindowOptions_infos_line(v_window, "User data directory", XMFS::getUserDir(FDT_DATA), p);
+ p+=20;
+ makeWindowOptions_infos_line(v_window, "User config directory", XMFS::getUserDir(FDT_CONFIG), p);
diff --git a/gnu/packages/patches/xmoto-utf8.patch b/gnu/packages/patches/xmoto-utf8.patch
new file mode 100644
index 0000000000..e5d0dfb2a4
--- /dev/null
+++ b/gnu/packages/patches/xmoto-utf8.patch
@@ -0,0 +1,16 @@
+Description: Build with g++'s new utf8.h
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/src/helpers/utf8.h
++++ b/src/helpers/utf8.h
+@@ -18,8 +18,8 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ =============================================================================*/
+
+-#ifndef __UTF8_H__
+-#define __UTF8_H__
++#ifndef __XMOTO_UTF8_H__
++#define __XMOTO_UTF8_H__
+
+ #include <vector>
+ #include <string>