summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-21 16:44:18 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-21 16:50:00 +0100
commit6839095af7f6c8a8d5ad481db22cd4ece0a1b5e3 (patch)
treefb792abf80252d2adfd3403ef3b8ac36ad94db59 /gnu/packages/patches
parentc450ee975529f25607e67cb405a2a6b515cf655e (diff)
downloadguix-patches-6839095af7f6c8a8d5ad481db22cd4ece0a1b5e3.tar
guix-patches-6839095af7f6c8a8d5ad481db22cd4ece0a1b5e3.tar.gz
gnu: mrustc: Update to 0.8.1.
* gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/rust.scm (mrustc): Update to 0.8.1. [source](patches): Remove it. [native-inputs]: Add zlib.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch b/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
deleted file mode 100644
index 9e76653a07..0000000000
--- a/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/thepowersgang/mrustc/issues/109
-From: Danny Milosavljevic <dannym@scratchpost.org>
-Date: Fri, 3 Jan 2019 13:00:00 +0100
-
---- mrustc/src/expand/proc_macro.cpp.orig 2019-02-01 14:16:54.208486062 +0100
-+++ mrustc/src/expand/proc_macro.cpp 2019-02-01 14:17:14.350925705 +0100
-@@ -977,7 +977,7 @@
- for(;;)
- {
- auto b = recv_u8();
-- v |= static_cast<uint64_t>(b) << ofs;
-+ v |= static_cast<uint64_t>(b & 0x7F) << ofs;
- if( (b & 0x80) == 0 )
- break;
- ofs += 7;