summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-11 17:47:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-11 17:54:49 +0200
commit5f022a51c49087b8a09736338cbba2d75a586431 (patch)
tree6dceea67320ad79d8833e9b5642b5f3b0c88d1bf /gnu/packages/patches
parent145484e8f5d89911f5f905c9fe604e3cbfd1e434 (diff)
downloadguix-patches-5f022a51c49087b8a09736338cbba2d75a586431.tar
guix-patches-5f022a51c49087b8a09736338cbba2d75a586431.tar.gz
gnu: clang-runtime-3.5: Fix build.
* gnu/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/llvm.scm (clang-runtime-3.5): Add patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch b/gnu/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch
new file mode 100644
index 0000000000..9e9d57d265
--- /dev/null
+++ b/gnu/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch
@@ -0,0 +1,29 @@
+Adjust libsanitizer to ABI change in glibc 2.31.
+
+Adapted to 3.x from this upstream commit:
+https://github.com/llvm/llvm-project/commit/947f9692440836dcb8d88b74b69dd379d85974ce
+
+--- a/lib/sanitizer_common/saniniitizer_platform_limits_posix.h.orig 2020-08-11 16:01:32.494882282 +0200 #
++++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.h 2020-08-11 16:32:49.711383554 +0200
+@@ -176,8 +176,7 @@
+ unsigned long __unused1;
+ unsigned long __unused2;
+ #else
+- unsigned short mode;
+- unsigned short __pad1;
++ unsigned int mode;
+ unsigned short __seq;
+ unsigned short __pad2;
+ #if defined(__x86_64__) && !defined(_LP64)
+--- a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-08-11 16:01:07.926821829 +0200
++++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc.orig 2020-08-11 16:01:03.698811421 +0200
+@@ -1056,7 +1056,9 @@
+ CHECK_SIZE_AND_OFFSET(ipc_perm, gid);
+ CHECK_SIZE_AND_OFFSET(ipc_perm, cuid);
+ CHECK_SIZE_AND_OFFSET(ipc_perm, cgid);
++#if !SANITIZER_LINUX || __GLIBC_PREREQ (2, 31)
+ CHECK_SIZE_AND_OFFSET(ipc_perm, mode);
++#endif
+
+ CHECK_TYPE_SIZE(shmid_ds);
+ CHECK_SIZE_AND_OFFSET(shmid_ds, shm_perm);