summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 00:22:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 00:43:24 +0100
commit570b89f4016d8e4913502176b6ca4ead511e2e8a (patch)
tree2e972129f2e7d8b9fc933dc9a0a21eae8227fe85 /gnu/packages/patches
parent21e733ce4eb5f15d195d129d659d1be373696a9c (diff)
downloadguix-patches-570b89f4016d8e4913502176b6ca4ead511e2e8a.tar
guix-patches-570b89f4016d8e4913502176b6ca4ead511e2e8a.tar.gz
gnu: gzdoom: Update to 4.3.2.
* gnu/packages/games.scm (gzdoom): Update to 4.3.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. Apply system libgme patch. Update snippet. [arguments]: Allow system libgme. Update substitution file names. [inputs]: Use fluidsynth@2. * gnu/packages/patches/gzdoom-find-system-libgme.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gzdoom-find-system-libgme.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/gzdoom-find-system-libgme.patch b/gnu/packages/patches/gzdoom-find-system-libgme.patch
new file mode 100644
index 0000000000..a7f277d614
--- /dev/null
+++ b/gnu/packages/patches/gzdoom-find-system-libgme.patch
@@ -0,0 +1,21 @@
+--- /CMakeLists.txt 2020-01-20 21:47:35.460119141 +0100
++++ /CMakeLists.txt 2020-01-20 21:47:47.690112400 +0100
+@@ -195,12 +195,12 @@
+ #endif()
+
+ # GME
+-#find_path( GME_INCLUDE_DIR gme/gme.h )
+-#find_library( GME_LIBRARIES gme )
+-#mark_as_advanced( GME_INCLUDE_DIR GME_LIBRARIES )
+-#FIND_PACKAGE_HANDLE_STANDARD_ARGS( GME
+-# REQUIRED_VARS GME_LIBRARIES GME_INCLUDE_DIR
+-#)
++find_path( GME_INCLUDE_DIR gme/gme.h )
++find_library( GME_LIBRARIES gme )
++mark_as_advanced( GME_INCLUDE_DIR GME_LIBRARIES )
++FIND_PACKAGE_HANDLE_STANDARD_ARGS( GME
++ REQUIRED_VARS GME_LIBRARIES GME_INCLUDE_DIR
++)
+
+ if( MSVC )
+ # Eliminate unreferenced functions and data