summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
commit50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64 (patch)
tree64f16d207bad28a9dfda9cce95e6337483a40066 /gnu/packages/patches
parenta8cb1e72ef351330d1521833c1b270dcc0da593f (diff)
parentafc57916e5398737e13d94b3823983783221eb63 (diff)
downloadguix-patches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar
guix-patches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/extempore-unbundle-external-dependencies.patch140
-rw-r--r--gnu/packages/patches/llvm-for-extempore.patch118
-rw-r--r--gnu/packages/patches/vlc-fix-test_libvlc_slaves.patch35
3 files changed, 140 insertions, 153 deletions
diff --git a/gnu/packages/patches/extempore-unbundle-external-dependencies.patch b/gnu/packages/patches/extempore-unbundle-external-dependencies.patch
new file mode 100644
index 0000000000..e9484f7994
--- /dev/null
+++ b/gnu/packages/patches/extempore-unbundle-external-dependencies.patch
@@ -0,0 +1,140 @@
+Remove build machinery for bundled dependencies.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 89e6125e..c5e90750 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,7 +36,7 @@ endif()
+ if(PACKAGE)
+ # this needs to be set before project() is called
+ set(CMAKE_OSX_DEPLOYMENT_TARGET 10.12)
+- set(ASSETS ON) # necessary for packaging
++ set(ASSETS OFF) # necessary for packaging
+ message(STATUS "Building Extempore for binary distribution (assets directory will be downloaded)")
+ endif()
+
+@@ -134,71 +134,6 @@ else()
+ message(FATAL_ERROR "Sorry, Extempore isn't supported on this platform - macOS, Linux & Windows only.")
+ endif()
+
+-########
+-# PCRE #
+-########
+-
+-# current in-tree PCRE version: 8.38
+-
+-add_library(pcre STATIC
+- # headers
+- src/pcre/config.h
+- src/pcre/pcre.h
+- src/pcre/ucp.h
+- # source files
+- src/pcre/pcre_chartables.c
+- src/pcre/pcre_compile.c
+- src/pcre/pcre_exec.c
+- src/pcre/pcre_globals.c
+- src/pcre/pcre_internal.h
+- src/pcre/pcre_newline.c
+- src/pcre/pcre_tables.c
+- )
+-
+-target_compile_definitions(pcre
+- PRIVATE -DHAVE_CONFIG_H
+- )
+-
+-if(PACKAGE)
+- target_compile_options(pcre
+- PRIVATE -mtune=generic)
+-endif()
+-
+-#############
+-# portaudio #
+-#############
+-
+-add_library(portaudio STATIC
+- src/portaudio/src/common/pa_allocation.c
+- src/portaudio/src/common/pa_allocation.h
+- src/portaudio/src/common/pa_converters.c
+- src/portaudio/src/common/pa_converters.h
+- src/portaudio/src/common/pa_cpuload.c
+- src/portaudio/src/common/pa_cpuload.h
+- src/portaudio/src/common/pa_debugprint.c
+- src/portaudio/src/common/pa_debugprint.h
+- src/portaudio/src/common/pa_dither.c
+- src/portaudio/src/common/pa_dither.h
+- src/portaudio/src/common/pa_endianness.h
+- src/portaudio/src/common/pa_front.c
+- src/portaudio/src/common/pa_hostapi.h
+- src/portaudio/src/common/pa_memorybarrier.h
+- src/portaudio/src/common/pa_process.c
+- src/portaudio/src/common/pa_process.h
+- src/portaudio/src/common/pa_ringbuffer.c
+- src/portaudio/src/common/pa_ringbuffer.h
+- src/portaudio/src/common/pa_stream.c
+- src/portaudio/src/common/pa_stream.h
+- src/portaudio/src/common/pa_trace.c
+- src/portaudio/src/common/pa_trace.h
+- src/portaudio/src/common/pa_types.h
+- src/portaudio/src/common/pa_util.h
+- )
+-
+-target_include_directories(portaudio
+- PRIVATE src/portaudio/include
+- PRIVATE src/portaudio/src/common)
+-
+ # platform-specific
+
+ if(APPLE)
+@@ -224,25 +159,8 @@ if(APPLE)
+
+ elseif(UNIX AND NOT APPLE)
+ # use ALSA on Linux
+- target_sources(portaudio
+- PRIVATE src/portaudio/src/hostapi/alsa/pa_linux_alsa.c
+- PRIVATE src/portaudio/src/os/unix/pa_unix_hostapis.c
+- PRIVATE src/portaudio/src/os/unix/pa_unix_util.c
+- )
+- target_include_directories(portaudio
+- PRIVATE src/portaudio/src/os/unix)
+- target_compile_definitions(portaudio
+- PRIVATE -DPA_USE_ALSA)
+- target_link_libraries(portaudio
+- PRIVATE asound)
+
+ if(JACK)
+- target_sources(portaudio
+- PRIVATE src/portaudio/src/hostapi/jack/pa_jack.c)
+- target_compile_definitions(portaudio
+- PRIVATE -DPA_USE_JACK)
+- target_link_libraries(portaudio
+- PRIVATE jack)
+ endif()
+
+ elseif(WIN32)
+@@ -292,8 +210,6 @@ if(ASIO)
+ endif()
+
+ if(PACKAGE)
+- target_compile_options(portaudio
+- PRIVATE -mtune=generic)
+ endif()
+
+ ##############
+@@ -411,8 +327,6 @@ endif()
+
+ # dependencies
+
+-add_dependencies(extempore pcre portaudio)
+-
+ if(BUILD_LLVM)
+ if(WIN32)
+ add_dependencies(extempore LLVM-install)
+@@ -553,7 +467,7 @@ else()
+ install(TARGETS extempore
+ RUNTIME
+ DESTINATION ".")
+- install(DIRECTORY assets runtime libs examples tests
++ install(DIRECTORY runtime libs examples
+ DESTINATION "."
+ PATTERN ".DS_Store" EXCLUDE)
+ endif()
diff --git a/gnu/packages/patches/llvm-for-extempore.patch b/gnu/packages/patches/llvm-for-extempore.patch
deleted file mode 100644
index 614682c6cb..0000000000
--- a/gnu/packages/patches/llvm-for-extempore.patch
+++ /dev/null
@@ -1,118 +0,0 @@
-This patch to LLVM is required by the developers of the Extempore language.
-The following explanation was posted to the extemporelang@googlegroups.com
-mailing list:
-
-"There is an assumption in the parser that all definitions occur within the
-same compilation unit - i.e. the parser has local state about what has been
-parsed in this unit of work. Extempore obviously does lots of little units
-rather than one big unit and this causes problems for named types that were
-defined in another unit - which they always are. The patch simply checks the
-current module to see if the type has been previously defined, and intervenes
-appropriately if it has."
-
-Message-ID: <CAOjrPOqoreXuZo4ZpDBvHE7M_tgAR_V8Txq5JFjh1HnGRn2EsA@mail.gmail.com>
-
---- llvm-3.7.1.src/include/llvm/MC/MCSectionCOFF.h 2015-04-11 12:11:45.000000000 +1000
-+++ llvm-3.7.1.src/include/llvm/MC/MCSectionCOFF.h 2015-09-14 09:22:56.000000000 +1000
-@@ -16,7 +16,6 @@
-
- #include "llvm/ADT/StringRef.h"
- #include "llvm/MC/MCSection.h"
--#include "llvm/Support/COFF.h"
-
- namespace llvm {
- class MCSymbol;
-
---- llvm-3.7.1.src/lib/AsmParser/LLParser.cpp 2015-07-11 20:30:36.000000000 +1000
-+++ llvm-3.7.1.src/lib/AsmParser/LLParser.cpp 2015-09-14 09:20:57.000000000 +1000
-@@ -1754,8 +1754,14 @@
- // If the type hasn't been defined yet, create a forward definition and
- // remember where that forward def'n was seen (in case it never is defined).
- if (!Entry.first) {
-- Entry.first = StructType::create(Context, Lex.getStrVal());
-- Entry.second = Lex.getLoc();
-+ // this here for extempore
-+ if (M->getTypeByName(Lex.getStrVal())) {
-+ Entry.first = M->getTypeByName(Lex.getStrVal());
-+ Entry.second = SMLoc();
-+ } else {
-+ Entry.first = StructType::create(Context, Lex.getStrVal());
-+ Entry.second = Lex.getLoc();
-+ }
- }
- Result = Entry.first;
- Lex.Lex();
-
---- llvm-3.7.1.src/lib/CodeGen/TargetLoweringObjectFileImpl.cpp 2015-07-01 05:10:31.000000000 +1000
-+++ llvm-3.7.1.src/lib/CodeGen/TargetLoweringObjectFileImpl.cpp 2015-09-14 09:23:40.000000000 +1000
-@@ -32,6 +32,7 @@
- #include "llvm/MC/MCStreamer.h"
- #include "llvm/MC/MCSymbolELF.h"
- #include "llvm/MC/MCValue.h"
-+#include "llvm/Support/COFF.h"
- #include "llvm/Support/Dwarf.h"
- #include "llvm/Support/ELF.h"
- #include "llvm/Support/ErrorHandling.h"
-
---- llvm-3.7.1.src/lib/ExecutionEngine/MCJIT/MCJIT.cpp 2015-07-31 02:31:16.000000000 +1000
-+++ llvm-3.7.1.src/lib/ExecutionEngine/MCJIT/MCJIT.cpp 2015-09-14 09:21:28.000000000 +1000
-@@ -524,6 +524,17 @@
- rv.IntVal = APInt(32, PF(ArgValues[0].IntVal.getZExtValue()));
- return rv;
- }
-+ if (FTy->getNumParams() == 1 &&
-+ RetTy->isVoidTy() &&
-+ FTy->getParamType(0)->isPointerTy()) {
-+ GenericValue rv;
-+ //void (*PF)(char *) = (void(*)(char *))(intptr_t)FPtr;
-+ //printf("are symbols available: %d\n",isSymbolSearchingDisabled());
-+ void (*PF)(char *) = (void(*)(char *))FPtr;
-+ char* mzone = (char*) GVTOP(ArgValues[0]);
-+ PF(mzone);
-+ return rv;
-+ }
- break;
- }
- }
-
---- llvm-3.7.1.src/lib/MC/MCContext.cpp 2015-06-23 21:31:32.000000000 +1000
-+++ llvm-3.7.1.src/lib/MC/MCContext.cpp 2015-09-14 09:24:01.000000000 +1000
-@@ -23,6 +23,7 @@
- #include "llvm/MC/MCSymbolCOFF.h"
- #include "llvm/MC/MCSymbolELF.h"
- #include "llvm/MC/MCSymbolMachO.h"
-+#include "llvm/Support/COFF.h"
- #include "llvm/Support/ELF.h"
- #include "llvm/Support/ErrorHandling.h"
- #include "llvm/Support/FileSystem.h"
-
---- llvm-3.7.1.src/lib/MC/MCObjectFileInfo.cpp 2015-06-25 10:28:42.000000000 +1000
-+++ llvm-3.7.1.src/lib/MC/MCObjectFileInfo.cpp 2015-09-14 09:24:17.000000000 +1000
-@@ -16,6 +16,7 @@
- #include "llvm/MC/MCSectionCOFF.h"
- #include "llvm/MC/MCSectionELF.h"
- #include "llvm/MC/MCSectionMachO.h"
-+#include "llvm/Support/COFF.h"
- using namespace llvm;
-
- static bool useCompactUnwind(const Triple &T) {
-
---- llvm-3.7.1.src/lib/MC/MCSectionCOFF.cpp 2015-06-09 10:31:39.000000000 +1000
-+++ llvm-3.7.1.src/lib/MC/MCSectionCOFF.cpp 2015-09-14 09:24:25.000000000 +1000
-@@ -11,6 +11,7 @@
- #include "llvm/MC/MCAsmInfo.h"
- #include "llvm/MC/MCContext.h"
- #include "llvm/MC/MCSymbol.h"
-+#include "llvm/Support/COFF.h"
- #include "llvm/Support/raw_ostream.h"
- using namespace llvm;
-
---- llvm-3.7.1.src/lib/Target/X86/X86TargetObjectFile.cpp 2015-06-27 04:55:48.000000000 +1000
-+++ llvm-3.7.1.src/lib/Target/X86/X86TargetObjectFile.cpp 2015-09-14 09:25:03.000000000 +1000
-@@ -16,6 +16,7 @@
- #include "llvm/MC/MCSectionCOFF.h"
- #include "llvm/MC/MCSectionELF.h"
- #include "llvm/MC/MCValue.h"
-+#include "llvm/Support/COFF.h"
- #include "llvm/Support/Dwarf.h"
- #include "llvm/Target/TargetLowering.h"
diff --git a/gnu/packages/patches/vlc-fix-test_libvlc_slaves.patch b/gnu/packages/patches/vlc-fix-test_libvlc_slaves.patch
deleted file mode 100644
index 9bc6d35f18..0000000000
--- a/gnu/packages/patches/vlc-fix-test_libvlc_slaves.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 4186c94104ee528abd6860611b49515f3e6ec644 Mon Sep 17 00:00:00 2001
-From: Thomas Guillem <thomas@gllm.fr>
-Date: Fri, 18 Oct 2019 10:34:07 +0200
-Subject: [PATCH] input/item: sort before attaching slaves
-
-The order of readdir() is completely filesystem dependent.
-
-Slaves should be attached using the same order across multiple OSses/access
-modules.
-
-This fixes the test_libvlc_slaves on some system when the entry order from
-readdir() is different.
-
-This patch need to be backported to VLC 3.0.
----
- src/input/item.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/input/item.c b/src/input/item.c
-index e8db39ca28..fbd74cc95f 100644
---- a/src/input/item.c
-+++ b/src/input/item.c
-@@ -1809,8 +1809,8 @@ void vlc_readdir_helper_finish(struct vlc_readdir_helper *p_rdh, bool b_success)
- {
- if (b_success)
- {
-- rdh_attach_slaves(p_rdh, p_rdh->p_node);
- rdh_sort(p_rdh->p_node);
-+ rdh_attach_slaves(p_rdh, p_rdh->p_node);
- }
- free(p_rdh->psz_ignored_exts);
-
---
-2.20.1
-