summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 20:43:03 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:16 -0500
commit49a9099ebc2cd3a31d274613f307b66cd0df2204 (patch)
treeb703fe8ddc7214e1a311e7de476932d18ef3a254 /gnu/packages/patches
parent7504007211b0b7864b2b8f4b3b1dcfbaaef2da30 (diff)
downloadguix-patches-49a9099ebc2cd3a31d274613f307b66cd0df2204.tar
guix-patches-49a9099ebc2cd3a31d274613f307b66cd0df2204.tar.gz
gnu: xf86-video-intel: Update to 2.21.15.
* gnu/packages/patches/xf86-video-intel-compat-api.patch, gnu/packages/patches/xf86-video-intel-glibc-2.20.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xorg.scm (xf86-video-intel): Update to 2.21.15. Add patches. Add eudev to inputs.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xf86-video-intel-compat-api.patch13
-rw-r--r--gnu/packages/patches/xf86-video-intel-glibc-2.20.patch15
2 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/xf86-video-intel-compat-api.patch b/gnu/packages/patches/xf86-video-intel-compat-api.patch
new file mode 100644
index 0000000000..786de5c45d
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-intel-compat-api.patch
@@ -0,0 +1,13 @@
+This patch was copied from Debian.
+
+--- xserver-xorg-video-intel-2.21.15.orig/src/compat-api.h
++++ xserver-xorg-video-intel-2.21.15/src/compat-api.h
+@@ -158,4 +158,8 @@
+ if ((d)->pScreen->SourceValidate) (d)->pScreen->SourceValidate(d, x, y, w, h)
+ #endif
+
++#if XORG_VERSION_CURRENT >= XORG_VERSION_NUMERIC(1,14,99,2,0)
++#define DamageUnregister(d, dd) DamageUnregister(dd)
++#endif
++
+ #endif
diff --git a/gnu/packages/patches/xf86-video-intel-glibc-2.20.patch b/gnu/packages/patches/xf86-video-intel-glibc-2.20.patch
new file mode 100644
index 0000000000..aeebfacdcd
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-intel-glibc-2.20.patch
@@ -0,0 +1,15 @@
+Allow builds with glibc 2.20.
+Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
+See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
+
+--- xf86-video-intel-2.21.15/src/intel_device.c.~1~ 2013-08-09 16:58:48.000000000 -0400
++++ xf86-video-intel-2.21.15/src/intel_device.c 2014-12-18 00:03:54.700759577 -0500
+@@ -33,6 +33,8 @@
+
+ #include <sys/ioctl.h>
+
++#include <xorg-server.h>
++
+ #include <pciaccess.h>
+ #include <xf86.h>
+ #include <xf86drm.h>