summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-25 00:03:36 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-25 00:03:36 +0200
commit436d4d1fbb425c26d716e9f789f1284ec088cc86 (patch)
tree42ca76a36038b78eef50666293b65a29a02a4a62 /gnu/packages/patches
parentc0412fedf85034d9e00e84e5ae5c415df1df6284 (diff)
downloadguix-patches-436d4d1fbb425c26d716e9f789f1284ec088cc86.tar
guix-patches-436d4d1fbb425c26d716e9f789f1284ec088cc86.tar.gz
gnu: Add doxygen.
* gnu/packages/doxygen.scm: New file. * gnu/packages/patches/doxygen-test.patch, gnu/packages/patches/doxygen-tmake.patch: New files. * gnu-system.am (GNU_SYSTEM_MODULES, dist_patch_DATA): Register the new files.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/doxygen-test.patch38
-rw-r--r--gnu/packages/patches/doxygen-tmake.patch24
2 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/patches/doxygen-test.patch b/gnu/packages/patches/doxygen-test.patch
new file mode 100644
index 0000000000..7a7f4e963f
--- /dev/null
+++ b/gnu/packages/patches/doxygen-test.patch
@@ -0,0 +1,38 @@
+Modify the expected outcome of test 012 so that it passes when bibtex is
+not in the path, as we do not wish to add texlive as an input just for this
+test.
+
+diff -u -r doxygen-1.8.7.orig/testing/012/citelist.xml doxygen-1.8.7/testing/012/citelist.xml
+--- doxygen-1.8.7.orig/testing/012/citelist.xml 2014-04-24 23:43:34.000000000 +0200
++++ doxygen-1.8.7/testing/012/citelist.xml 2014-04-24 23:49:43.000000000 +0200
+@@ -4,17 +4,6 @@
+ <compoundname>citelist</compoundname>
+ <title>Bibliography</title>
+ <detaileddescription>
+- <para>
+- <variablelist>
+- <varlistentry>
+- <term><anchor id="_1CITEREF_knuth79"/>[1]</term>
+- </varlistentry>
+- <listitem>
+- <para>Donald<nonbreakablespace/>E. Knuth. <emphasis>Tex and Metafont, New Directions in Typesetting</emphasis>. American Mathematical Society and Digital Press, Stanford, 1979.</para>
+- <para/>
+- </listitem>
+- </variablelist>
+- </para>
+ </detaileddescription>
+ </compounddef>
+ </doxygen>
+diff -u -r doxygen-1.8.7.orig/testing/012/indexpage.xml doxygen-1.8.7/testing/012/indexpage.xml
+--- doxygen-1.8.7.orig/testing/012/indexpage.xml 2014-04-24 23:43:34.000000000 +0200
++++ doxygen-1.8.7/testing/012/indexpage.xml 2014-04-24 23:44:05.000000000 +0200
+@@ -4,7 +4,7 @@
+ <compoundname>index</compoundname>
+ <title>My Project</title>
+ <detaileddescription>
+- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[1]</ref> for more info. </para>
++ <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">knuth79</ref> for more info. </para>
+ </detaileddescription>
+ </compounddef>
+ </doxygen>
+Nur in doxygen-1.8.7/testing: test_output_012.
diff --git a/gnu/packages/patches/doxygen-tmake.patch b/gnu/packages/patches/doxygen-tmake.patch
new file mode 100644
index 0000000000..3579243702
--- /dev/null
+++ b/gnu/packages/patches/doxygen-tmake.patch
@@ -0,0 +1,24 @@
+Fix the `check_unix' function, which looks for `/bin/uname' to determine
+whether we're on a Unix-like system.
+Taken from nixpkgs.
+
+--- doxygen-1.5.8/tmake/bin/tmake 2008-12-06 14:16:20.000000000 +0100
++++ doxygen-1.5.8/tmake/bin/tmake 2009-03-05 11:29:55.000000000 +0100
+@@ -234,17 +234,7 @@ sub tmake_verb {
+ #
+
+ sub check_unix {
+- my($r);
+- $r = 0;
+- if ( -f "/bin/uname" ) {
+- $r = 1;
+- (-f "\\bin\\uname") && ($r = 0);
+- }
+- if ( -f "/usr/bin/uname" ) {
+- $r = 1;
+- (-f "\\usr\\bin\\uname") && ($r = 0);
+- }
+- return $r;
++ return 1;
+ }
+