summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMatthew Kraai <kraai@ftbfs.org>2020-12-07 14:47:39 -0800
committerJakub Kądziołka <kuba@kadziolka.net>2021-01-02 19:19:57 +0100
commit402e697a1144788102b16ca8c9ea74607d2c2c3c (patch)
tree588373a52ce94dde9fd04786271ac8d2ba86af0f /gnu/packages/patches
parent7d0e111e272dc9f337f8907310f561e22a3ef329 (diff)
downloadguix-patches-402e697a1144788102b16ca8c9ea74607d2c2c3c.tar
guix-patches-402e697a1144788102b16ca8c9ea74607d2c2c3c.tar.gz
gnu: Add Rust 1.48.
* gnu/packages/rust.scm (rust-1.48): New variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rust-1.48-linker-locale.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.48-linker-locale.patch b/gnu/packages/patches/rust-1.48-linker-locale.patch
new file mode 100644
index 0000000000..d06dcbe682
--- /dev/null
+++ b/gnu/packages/patches/rust-1.48-linker-locale.patch
@@ -0,0 +1,14 @@
+https://github.com/rust-lang/rust/pull/74416
+diff --git a/compiler/rustc_codegen_ssa/src/back/linker.rs b/compiler/rustc_codegen_ssa/src/back/linker.rs
+index 3df956c465e..f45fee45be4 100644
+--- a/compiler/rustc_codegen_ssa/src/back/linker.rs
++++ b/compiler/rustc_codegen_ssa/src/back/linker.rs
+@@ -28,7 +28,7 @@
+ pub fn disable_localization(linker: &mut Command) {
+ // No harm in setting both env vars simultaneously.
+ // Unix-style linkers.
+- linker.env("LC_ALL", "C");
++ linker.env("LC_ALL", "en_US.UTF-8");
+ // MSVC's `link.exe`.
+ linker.env("VSLANG", "1033");
+ }