summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
commit3f9543aee1e49001d0f80542dd71ba73c44787c7 (patch)
tree50ee1bdd53b1e5ec69cb8655f23da79c332dde1e /gnu/packages/patches
parent864a9590ad948df09f2ad6e9e929608a7587a5f7 (diff)
parenta71c863834448e2645518b31b60a96ef488dd761 (diff)
downloadguix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar
guix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hmmer-remove-cpu-specificity.patch22
-rw-r--r--gnu/packages/patches/python-pandas-skip-failing-tests.patch44
-rw-r--r--gnu/packages/patches/wget-CVE-2017-6508.patch45
3 files changed, 84 insertions, 27 deletions
diff --git a/gnu/packages/patches/hmmer-remove-cpu-specificity.patch b/gnu/packages/patches/hmmer-remove-cpu-specificity.patch
new file mode 100644
index 0000000000..ba98db4d0e
--- /dev/null
+++ b/gnu/packages/patches/hmmer-remove-cpu-specificity.patch
@@ -0,0 +1,22 @@
+This patch removes compilation flags which make the build for the machine
+where compilation takes place, rendering the build not reproducible.
+
+diff --git a/configure b/configure
+index 8b6aaef..49a6afc 100755
+--- a/configure
++++ b/configure
+@@ -6125,14 +6125,6 @@ fi # guess arch
+
+ if test "x$ax_gcc_arch" != x -a "x$ax_gcc_arch" != xno; then
+ for arch in $ax_gcc_arch; do
+- if test "x$acx_maxopt_portable" = xyes; then # if we require portable code
+- flags="-mtune=$arch"
+- # -mcpu=$arch and m$arch generate nonportable code on every arch except
+- # x86. And some other arches (e.g. Alpha) don't accept -mtune. Grrr.
+- case $host_cpu in i*86|x86_64*) flags="$flags -mcpu=$arch -m$arch";; esac
+- else
+- flags="-march=$arch -mcpu=$arch -m$arch"
+- fi
+ for flag in $flags; do
+ as_CACHEVAR=`$as_echo "ax_cv_check_cflags__$flag" | $as_tr_sh`
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts $flag" >&5
diff --git a/gnu/packages/patches/python-pandas-skip-failing-tests.patch b/gnu/packages/patches/python-pandas-skip-failing-tests.patch
index 31fc912d00..8ac330c18f 100644
--- a/gnu/packages/patches/python-pandas-skip-failing-tests.patch
+++ b/gnu/packages/patches/python-pandas-skip-failing-tests.patch
@@ -2,39 +2,29 @@ These tests fail on 32bit architectures.
Upstream bug URL: https://github.com/pandas-dev/pandas/issues/14866
---- a/pandas/tests/test_base.py 2017-03-08 17:49:44.422282717 +0100
-+++ b/pandas/tests/test_base.py 2017-03-08 17:50:59.476701799 +0100
-@@ -363,30 +363,6 @@
- self.assertFalse(result.iat[0])
- self.assertFalse(result.iat[1])
+--- a/pandas/tests/indexes/common.py 2017-03-09 00:10:26.063996176 +0100
++++ b/pandas/tests/indexes/common.py 2017-03-09 00:10:53.152844191 +0100
+@@ -119,20 +119,6 @@
+ with tm.assertRaisesRegexp(ValueError, 'Invalid fill method'):
+ idx.get_indexer(idx, method='invalid')
- def test_ndarray_compat_properties(self):
-
-- for o in self.objs:
+- idx = self.create_index()
+- self.assertTrue(idx.T.equals(idx))
+- self.assertTrue(idx.transpose().equals(idx))
-
-- # check that we work
-- for p in ['shape', 'dtype', 'flags', 'T', 'strides', 'itemsize',
-- 'nbytes']:
-- self.assertIsNotNone(getattr(o, p, None))
-- self.assertTrue(hasattr(o, 'base'))
+- values = idx.values
+- for prop in self._compat_props:
+- self.assertEqual(getattr(idx, prop), getattr(values, prop))
-
-- # if we have a datetimelike dtype then needs a view to work
-- # but the user is responsible for that
-- try:
-- self.assertIsNotNone(o.data)
-- except ValueError:
-- pass
+- # test for validity
+- idx.nbytes
+- idx.values.nbytes
-
-- self.assertRaises(ValueError, o.item) # len > 1
-- self.assertEqual(o.ndim, 1)
-- self.assertEqual(o.size, len(o))
--
-- self.assertEqual(Index([1]).item(), 1)
-- self.assertEqual(Series([1]).item(), 1)
--
- def test_ops(self):
- for op in ['max', 'min']:
- for o in self.objs:
+ def test_repr_roundtrip(self):
+
+ idx = self.create_index()
--- a/pandas/tools/tests/test_tile.py 2017-03-08 17:47:39.762261841 +0100
+++ b/pandas/tools/tests/test_tile.py 2017-03-08 17:48:26.831780495 +0100
@@ -271,19 +271,6 @@
diff --git a/gnu/packages/patches/wget-CVE-2017-6508.patch b/gnu/packages/patches/wget-CVE-2017-6508.patch
new file mode 100644
index 0000000000..0218fceaad
--- /dev/null
+++ b/gnu/packages/patches/wget-CVE-2017-6508.patch
@@ -0,0 +1,45 @@
+Fix CVE-2017-6508:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6508
+
+Patch copied from upstream source repository:
+
+https://git.savannah.gnu.org/cgit/wget.git/commit/?id=4d729e322fae359a1aefaafec1144764a54e8ad4
+
+From 4d729e322fae359a1aefaafec1144764a54e8ad4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Mon, 6 Mar 2017 10:04:22 +0100
+Subject: [PATCH] Fix CRLF injection in Wget host part
+
+* src/url.c (url_parse): Reject control characters in host part of URL
+
+Reported-by: Orange Tsai
+---
+ src/url.c | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/src/url.c b/src/url.c
+index 8f8ff0b8..7d36b27d 100644
+--- a/src/url.c
++++ b/src/url.c
+@@ -925,6 +925,17 @@ url_parse (const char *url, int *error, struct iri *iri, bool percent_encode)
+ url_unescape (u->host);
+ host_modified = true;
+
++ /* check for invalid control characters in host name */
++ for (p = u->host; *p; p++)
++ {
++ if (c_iscntrl(*p))
++ {
++ url_free(u);
++ error_code = PE_INVALID_HOST_NAME;
++ goto error;
++ }
++ }
++
+ /* Apply IDNA regardless of iri->utf8_encode status */
+ if (opt.enable_iri && iri)
+ {
+--
+2.12.0
+