summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
commit378ebc048c033744b4f1dc13e16f4f2277d7529f (patch)
tree8411f2a9348d47858b2aca849377e91ea7f90833 /gnu/packages/patches
parentd99e7ee0f2bbe4abe08552afaa9821036da2a760 (diff)
parent64855281c18bab87a61c77a18c9001e6e222fb08 (diff)
downloadguix-patches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar
guix-patches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/id3lib-UTF16-writing-bug.patch39
-rw-r--r--gnu/packages/patches/nsis-env-passthru.patch12
-rw-r--r--gnu/packages/patches/parted-glibc-compat.patch17
-rw-r--r--gnu/packages/patches/strace-ipc-tests.patch30
4 files changed, 51 insertions, 47 deletions
diff --git a/gnu/packages/patches/id3lib-UTF16-writing-bug.patch b/gnu/packages/patches/id3lib-UTF16-writing-bug.patch
new file mode 100644
index 0000000000..4a8f69b321
--- /dev/null
+++ b/gnu/packages/patches/id3lib-UTF16-writing-bug.patch
@@ -0,0 +1,39 @@
+diff -ruN id3lib-3.8.3.orig/ChangeLog id3lib-3.8.3/ChangeLog
+--- id3lib-3.8.3.orig/ChangeLog 2003-03-02 01:23:00.000000000 +0100
++++ id3lib-3.8.3/ChangeLog 2006-02-22 00:33:59.946214472 +0100
+@@ -1,3 +1,8 @@
++2006-02-17 Jerome Couderc
++
++ * Patch from Spoon to fix UTF-16 writing bug
++ http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979
++
+ 2003-03-02 Sunday 17:38 Thijmen Klok <thijmen@id3lib.org>
+
+ * THANKS (1.20): added more people
+diff -ruN id3lib-3.8.3.orig/src/io_helpers.cpp id3lib-3.8.3/src/io_helpers.cpp
+--- id3lib-3.8.3.orig/src/io_helpers.cpp 2003-03-02 01:23:00.000000000 +0100
++++ id3lib-3.8.3/src/io_helpers.cpp 2006-02-22 00:35:02.926639992 +0100
+@@ -363,11 +363,22 @@
+ // Write the BOM: 0xFEFF
+ unicode_t BOM = 0xFEFF;
+ writer.writeChars((const unsigned char*) &BOM, 2);
++ // Patch from Spoon : 2004-08-25 14:17
++ // http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979
++ // Wrong code
++ //for (size_t i = 0; i < size; i += 2)
++ //{
++ // unicode_t ch = (data[i] << 8) | data[i+1];
++ // writer.writeChars((const unsigned char*) &ch, 2);
++ //}
++ // Right code
++ unsigned char *pdata = (unsigned char *) data.c_str();
+ for (size_t i = 0; i < size; i += 2)
+ {
+- unicode_t ch = (data[i] << 8) | data[i+1];
++ unicode_t ch = (pdata[i] << 8) | pdata[i+1];
+ writer.writeChars((const unsigned char*) &ch, 2);
+ }
++ // End patch
+ }
+ return writer.getCur() - beg;
+ }
diff --git a/gnu/packages/patches/nsis-env-passthru.patch b/gnu/packages/patches/nsis-env-passthru.patch
new file mode 100644
index 0000000000..36b4092230
--- /dev/null
+++ b/gnu/packages/patches/nsis-env-passthru.patch
@@ -0,0 +1,12 @@
+--- nsis-3.04-src/SConstruct 2019-05-30 14:53:30.276775332 -0400
++++ nsis-3.04-src/SConstruct 2019-05-30 14:54:17.901232914 -0400
+@@ -77,6 +77,9 @@
+ if not toolset and not path:
+ defenv = Environment(TARGET_ARCH = arch)
+
++import os;
++defenv['ENV'] = os.environ
++
+ Export('defenv')
+
+ ######################################################################
diff --git a/gnu/packages/patches/parted-glibc-compat.patch b/gnu/packages/patches/parted-glibc-compat.patch
deleted file mode 100644
index edf4afb0d1..0000000000
--- a/gnu/packages/patches/parted-glibc-compat.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Include <sys/sysmacros.h> for "major" and "minor".
-
-Taken from upstream:
-https://git.savannah.gnu.org/cgit/parted.git/commit/?id=ba5e0451b51c983e40afd123b6e0d3eddb55e610
-
-diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
-index 31b98ab..7e86b51 100644
---- a/libparted/arch/linux.c
-+++ b/libparted/arch/linux.c
-@@ -41,6 +41,7 @@
- #include <sys/utsname.h> /* for uname() */
- #include <scsi/scsi.h>
- #include <assert.h>
-+#include <sys/sysmacros.h>
- #ifdef ENABLE_DEVICE_MAPPER
- #include <libdevmapper.h>
- #endif
diff --git a/gnu/packages/patches/strace-ipc-tests.patch b/gnu/packages/patches/strace-ipc-tests.patch
deleted file mode 100644
index 49341765ca..0000000000
--- a/gnu/packages/patches/strace-ipc-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Fix a test failure on some systems.
-
-Taken from upstream:
-https://github.com/strace/strace/commit/4377e3a1535a0ec3a42da8a1366ad6943f4efa0e
-
-diff --git a/tests/gen_tests.in b/tests/gen_tests.in
-index 4a506b94c..4fdf4722c 100644
---- a/tests/gen_tests.in
-+++ b/tests/gen_tests.in
-@@ -168,16 +168,16 @@ ipc_msg-Xabbrev +ipc.sh -Xabbrev -a26
- ipc_msg-Xraw +ipc.sh -Xraw -a16
- ipc_msg-Xverbose +ipc.sh -Xverbose -a34
- ipc_msgbuf-Xabbrev +ipc_msgbuf.test -Xabbrev
--ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a22
-+ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a20
- ipc_msgbuf-Xverbose +ipc_msgbuf.test -Xverbose
- ipc_sem +ipc.sh -a29
- ipc_sem-Xabbrev +ipc.sh -Xabbrev -a29
- ipc_sem-Xraw +ipc.sh -Xraw -a19
- ipc_sem-Xverbose +ipc.sh -Xverbose -a36
--ipc_shm +ipc.sh -a29
--ipc_shm-Xabbrev +ipc.sh -Xabbrev -a29
-+ipc_shm +ipc.sh -a26
-+ipc_shm-Xabbrev +ipc.sh -Xabbrev -a26
- ipc_shm-Xraw +ipc.sh -Xraw -a19
--ipc_shm-Xverbose +ipc.sh -Xverbose -a36
-+ipc_shm-Xverbose +ipc.sh -Xverbose -a34
- kcmp -a22
- kcmp-y -a22 -y -e trace=kcmp
- kern_features -a16