summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-05-14 21:02:23 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-05-14 21:05:32 +0200
commit3617d4f913b2ab53420d3f696126d5c2bd20ea2a (patch)
tree05aa7c2f21637f0a2766f779fded7a1c9ec39964 /gnu/packages/patches
parent9f5a3ba659ff50d324c95473ef921b8924d1c759 (diff)
downloadguix-patches-3617d4f913b2ab53420d3f696126d5c2bd20ea2a.tar
guix-patches-3617d4f913b2ab53420d3f696126d5c2bd20ea2a.tar.gz
gnu: ocaml-base64: Update to 3.2.0.
* gnu/packages/ocaml.scm (ocaml-base64): Update to 3.2.0. [origin]: Use git-fetch. (ocaml-piqilib)[origin]: Add a patch to fix building with new versions of ocaml-base64. * gnu/packages/patches/ocaml-piqilib-Update-base64.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ocaml-piqilib-Update-base64.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/patches/ocaml-piqilib-Update-base64.patch b/gnu/packages/patches/ocaml-piqilib-Update-base64.patch
new file mode 100644
index 0000000000..ec2c02d93e
--- /dev/null
+++ b/gnu/packages/patches/ocaml-piqilib-Update-base64.patch
@@ -0,0 +1,46 @@
+From 98abdbff3d5316a75f27d6a76fe09317d56f2a38 Mon Sep 17 00:00:00 2001
+From: Vincent Bernardoff <vb@luminar.eu.org>
+Date: Sun, 10 Feb 2019 14:47:07 +0100
+Subject: [PATCH] Fix compilation with newer base64 versions
+
+---
+ opam | 2 +-
+ piqilib/piqi_base64.ml | 9 ++++-----
+ 2 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/opam b/opam
+index 3a9128e..bb5a53f 100644
+--- a/opam
++++ b/opam
+@@ -26,6 +26,6 @@ depends: [
+ "easy-format"
+ "ulex"
+ "xmlm"
+- "base64" {>="2.0.0"}
++ "base64" {>="3.1.0"}
+ ]
+ dev-repo: "git://github.com/alavrik/piqi"
+diff --git a/piqilib/piqi_base64.ml b/piqilib/piqi_base64.ml
+index c5a6ae7..a98346e 100644
+--- a/piqilib/piqi_base64.ml
++++ b/piqilib/piqi_base64.ml
+@@ -18,12 +18,11 @@
+ (* TODO: add more base64 validation; the base64 library doesn't do any
+ * validation *)
+ let decode x =
+- try
+- B64.decode x
+- with _ ->
+- invalid_arg "Piqi_base64.decode"
++ match Base64.decode x with
++ | Error _ -> invalid_arg "Piqi_base64.decode"
++ | Ok v -> v
+
+
+ let encode x =
+- B64.encode x
++ Base64.encode_exn x
+
+--
+2.21.0
+