summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-04 18:13:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-04 22:58:57 +0100
commit1a246c01c6d573b6226fd273f648d231e6ec38f1 (patch)
treeb3c242e519657b4bf5600b66d746fe4ebccfcde5 /gnu/packages/patches
parentd9ea7a734db21d5b608bd8ee30359b1ef44c1d25 (diff)
downloadguix-patches-1a246c01c6d573b6226fd273f648d231e6ec38f1.tar
guix-patches-1a246c01c6d573b6226fd273f648d231e6ec38f1.tar.gz
gnu: python-pytest: Update to 4.3.0.
* gnu/packages/patches/python-pytest-pluggy-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/check.scm (python-pytest): Update to 4.3.0. [source](patches): New field. [arguments]: Skip five new tests. Disable tests by passing them as arguments.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-pytest-pluggy-compat.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-pytest-pluggy-compat.patch b/gnu/packages/patches/python-pytest-pluggy-compat.patch
new file mode 100644
index 0000000000..ac33b862e6
--- /dev/null
+++ b/gnu/packages/patches/python-pytest-pluggy-compat.patch
@@ -0,0 +1,64 @@
+Fix test failures when built against Pluggy 0.9.
+
+Taken from this upstream commit:
+https://github.com/pytest-dev/pytest/commit/a68f4fd2b9e99c82476d0e04ebcf561aeddbcb2e
+
+diff --git a/testing/test_assertion.py b/testing/test_assertion.py
+index b659233eb..e4fe56c6f 100644
+--- a/testing/test_assertion.py
++++ b/testing/test_assertion.py
+@@ -209,7 +209,7 @@ def load(self, require=True, *args, **kwargs):
+ import spamplugin
+ return spamplugin
+
+- def iter_entry_points(name):
++ def iter_entry_points(group, name=None):
+ yield DummyEntryPoint()
+
+ pkg_resources.iter_entry_points = iter_entry_points
+diff --git a/testing/test_config.py b/testing/test_config.py
+index f9f22a63e..1e29b83f1 100644
+--- a/testing/test_config.py
++++ b/testing/test_config.py
+@@ -514,8 +514,8 @@ def test_preparse_ordering_with_setuptools(testdir, monkeypatch):
+ pkg_resources = pytest.importorskip("pkg_resources")
+ monkeypatch.delenv("PYTEST_DISABLE_PLUGIN_AUTOLOAD", raising=False)
+
+- def my_iter(name):
+- assert name == "pytest11"
++ def my_iter(group, name=None):
++ assert group == "pytest11"
+
+ class Dist(object):
+ project_name = "spam"
+@@ -552,8 +552,8 @@ def test_setuptools_importerror_issue1479(testdir, monkeypatch):
+ pkg_resources = pytest.importorskip("pkg_resources")
+ monkeypatch.delenv("PYTEST_DISABLE_PLUGIN_AUTOLOAD", raising=False)
+
+- def my_iter(name):
+- assert name == "pytest11"
++ def my_iter(group, name=None):
++ assert group == "pytest11"
+
+ class Dist(object):
+ project_name = "spam"
+@@ -583,8 +583,8 @@ def test_plugin_preparse_prevents_setuptools_loading(testdir, monkeypatch, block
+
+ plugin_module_placeholder = object()
+
+- def my_iter(name):
+- assert name == "pytest11"
++ def my_iter(group, name=None):
++ assert group == "pytest11"
+
+ class Dist(object):
+ project_name = "spam"
+@@ -621,7 +621,7 @@ def load(self):
+ def test_disable_plugin_autoload(testdir, monkeypatch, parse_args, should_load):
+ pkg_resources = pytest.importorskip("pkg_resources")
+
+- def my_iter(name):
++ def my_iter(group, name=None):
+ raise AssertionError("Should not be called")
+
+ class PseudoPlugin(object):