summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-25 11:40:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-26 22:47:16 +0300
commit196c8b3739d16241da73c78536ce86aaab948677 (patch)
treeeb9c062f8c2e085e138f1a35c3dc57408560d5fe /gnu/packages/patches
parente5e5eb1fcf4c0aab10e2d6ed7fa34257a3c87e58 (diff)
downloadguix-patches-196c8b3739d16241da73c78536ce86aaab948677.tar
guix-patches-196c8b3739d16241da73c78536ce86aaab948677.tar.gz
gnu: translate-shell: Update to 0.9.6.7.
* gnu/packages/patches/translate-shell-fix-curl-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/dictionaries.scm (translate-shell): Update to 0.9.6.7. [source](patches): Add it. [home-page]: Append slash.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/translate-shell-fix-curl-tests.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/patches/translate-shell-fix-curl-tests.patch b/gnu/packages/patches/translate-shell-fix-curl-tests.patch
new file mode 100644
index 0000000000..33731462b8
--- /dev/null
+++ b/gnu/packages/patches/translate-shell-fix-curl-tests.patch
@@ -0,0 +1,60 @@
+This patch fixes Curl related tests for 'translate-shell'.
+
+Upstream bug URL:
+
+https://github.com/soimort/translate-shell/issues/221
+
+From bb9f32d3145125ba664b6b05bf0a2fd34108e9d2 Mon Sep 17 00:00:00 2001
+From: Mort Yao <soi@mort.ninja>
+Date: Sun, 25 Mar 2018 03:14:33 +0200
+Subject: [PATCH] TestUtils: perform curl-related tests only if NETWORK_ACCESS
+ is set to yes (#221)
+
+---
+ test/TestUtils.awk | 32 +++++++++++++++++---------------
+ 1 file changed, 17 insertions(+), 15 deletions(-)
+
+diff --git a/test/TestUtils.awk b/test/TestUtils.awk
+index 08bb2e9..1c141e5 100644
+--- a/test/TestUtils.awk
++++ b/test/TestUtils.awk
+@@ -30,22 +30,24 @@ BEGIN {
+ assertTrue(newerVersion("2", "1.9.9999"))
+ }
+
+- T("curl()", 1)
+- {
+- delete tokens; delete ast
+- tokenize(tokens, curl("https://httpbin.org/get"))
+- parseJson(ast, tokens)
+- assertEqual(unparameterize(ast[0 SUBSEP "url"]),
+- "https://httpbin.org/get")
+- }
++ if (yn(ENVIRON["NETWORK_ACCESS"])) { # if network access enabled
++ T("curl()", 1)
++ {
++ delete tokens; delete ast
++ tokenize(tokens, curl("https://httpbin.org/get"))
++ parseJson(ast, tokens)
++ assertEqual(unparameterize(ast[0 SUBSEP "url"]),
++ "https://httpbin.org/get")
++ }
+
+- T("curlPost()", 1)
+- {
+- delete tokens; delete ast
+- tokenize(tokens, curlPost("https://httpbin.org/post", "fizz=buzz"))
+- parseJson(ast, tokens)
+- assertEqual(unparameterize(ast[0 SUBSEP "url"]),
+- "https://httpbin.org/post")
++ T("curlPost()", 1)
++ {
++ delete tokens; delete ast
++ tokenize(tokens, curlPost("https://httpbin.org/post", "fizz=buzz"))
++ parseJson(ast, tokens)
++ assertEqual(unparameterize(ast[0 SUBSEP "url"]),
++ "https://httpbin.org/post")
++ }
+ }
+
+ T("dump()", 3)