summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2022-01-29 00:53:31 -0600
committerEric Bavier <bavier@posteo.net>2022-01-29 00:53:31 -0600
commit1949c8b20612d476f64586f3a3812b051774a320 (patch)
tree633305639f2b0ec84d61bf71076ddf0610378ce6 /gnu/packages/patches
parentbbe52d3b86c06857eca2722fada77be060b145f5 (diff)
downloadguix-patches-1949c8b20612d476f64586f3a3812b051774a320.tar
guix-patches-1949c8b20612d476f64586f3a3812b051774a320.tar.gz
gnu: cpulimit: Fix build with glibc-2.32.
* gnu/packages/patches/cpulimit-with-glib-2.32.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/admin.scm (cpulimit)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cpulimit-with-glib-2.32.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/cpulimit-with-glib-2.32.patch b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
new file mode 100644
index 0000000000..4c0bbaac7c
--- /dev/null
+++ b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
@@ -0,0 +1,35 @@
+From 4a4794e041edf85cb67b9fbba66ad1a22fdcaaec Mon Sep 17 00:00:00 2001
+From: Eric Bavier <bavier@posteo.net>
+Date: Sat, 29 Jan 2022 00:10:20 -0600
+Subject: [PATCH] Fixes linux build with glibc-2.32.
+
+* cpulimit.c: Guard inclusion of <sys/sysctl.h> which is needed only for
+ __APPLE__ and is deprecated and unavailable starting with glibc-2.32.
+---
+ src/cpulimit.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Submitted upstream at https://github.com/opsengine/cpulimit/pull/105
+
+diff --git a/src/cpulimit.c b/src/cpulimit.c
+index 50eabea..be8cf22 100644
+--- a/src/cpulimit.c
++++ b/src/cpulimit.c
+@@ -38,13 +38,13 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-#include <sys/sysctl.h>
+ #include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+
+ #ifdef __APPLE__ || __FREEBSD__
+ #include <libgen.h>
++#include <sys/sysctl.h>
+ #endif
+
+ #include "process_group.h"
+--
+2.34.0
+