summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-02-12 15:33:43 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-15 14:31:33 +0100
commit13c8e747e86e39c0a8c6ec7da8c812d9bbcb682b (patch)
treea5db0fc9403a15d0f9c033bfaf757599b495d681 /gnu/packages/patches
parent7d9f8db2a88ff1047dfcf72a8ea0568003475c43 (diff)
downloadguix-patches-13c8e747e86e39c0a8c6ec7da8c812d9bbcb682b.tar
guix-patches-13c8e747e86e39c0a8c6ec7da8c812d9bbcb682b.tar.gz
gnu: containerd: Fix test failure with Go 1.13.
* gnu/packages/docker.scm (containerd)[source]: Add patch. * gnu/packages/patches/containerd-test-with-go1.13.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/containerd-test-with-go1.13.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/containerd-test-with-go1.13.patch b/gnu/packages/patches/containerd-test-with-go1.13.patch
new file mode 100644
index 0000000000..964adee9e6
--- /dev/null
+++ b/gnu/packages/patches/containerd-test-with-go1.13.patch
@@ -0,0 +1,21 @@
+Compatibility fix for go 1.13, flag.Parse() shouldn't be called during
+package initialization.
+https://golang.org/doc/go1.13#testing
+--- a/client_test.go 2020-02-12 14:50:28.991245371 -0500
++++ b/client_test.go 2020-02-12 15:12:37.383523980 -0500
+@@ -49,7 +49,6 @@
+ flag.StringVar(&address, "address", defaultAddress, "The address to the containerd socket for use in the tests")
+ flag.BoolVar(&noDaemon, "no-daemon", false, "Do not start a dedicated daemon for the tests")
+ flag.BoolVar(&noCriu, "no-criu", false, "Do not run the checkpoint tests")
+- flag.Parse()
+ }
+
+ func testContext() (context.Context, context.CancelFunc) {
+@@ -59,6 +58,7 @@
+ }
+
+ func TestMain(m *testing.M) {
++ flag.Parse()
+ if testing.Short() {
+ os.Exit(m.Run())
+ }