summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-01-24 15:01:00 +0100
committerJohn Darrington <jmd@gnu.org>2014-07-18 06:45:33 +0200
commit0e534e74aa68cea63302db19e7e39a72d0280b3d (patch)
tree7808b5405733975b65e072ccb7f889bc94b55f45 /gnu/packages/patches
parenta4dc3bdb15950d4f5651150643caeda34c1e2657 (diff)
downloadguix-patches-0e534e74aa68cea63302db19e7e39a72d0280b3d.tar
guix-patches-0e534e74aa68cea63302db19e7e39a72d0280b3d.tar.gz
gnu: Add Aegis.
* gnu/packages/version-control.scm (aegis): New variable. * gnu/packages/patches/aegis-constness-error.patch: New file. * gnu/packages/patches/aegis-perl-tempdir1.patch: New file. * gnu/packages/patches/aegis-perl-tempdir2.patch: New file. * gnu/packages/patches/aegis-test-fixup-1.patch: New file. * gnu/packages/patches/aegis-test-fixup-2.patch: New file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/aegis-constness-error.patch12
-rw-r--r--gnu/packages/patches/aegis-perl-tempdir1.patch14
-rw-r--r--gnu/packages/patches/aegis-perl-tempdir2.patch18
-rw-r--r--gnu/packages/patches/aegis-test-fixup-1.patch15
-rw-r--r--gnu/packages/patches/aegis-test-fixup-2.patch24
5 files changed, 83 insertions, 0 deletions
diff --git a/gnu/packages/patches/aegis-constness-error.patch b/gnu/packages/patches/aegis-constness-error.patch
new file mode 100644
index 0000000000..2a6c9d2c37
--- /dev/null
+++ b/gnu/packages/patches/aegis-constness-error.patch
@@ -0,0 +1,12 @@
+Fixes a fatal constness error with g++ 4.8.2.
+--- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
+@@ -182,7 +182,7 @@
+
+ // Use optimizations in memchr when possible.
+ if (needle_len == 1)
+- return memchr(haystack, *needle, haystack_len);
++ return (void *) memchr(haystack, *needle, haystack_len);
+
+ // Minimizing the worst-case complexity:
+ // Let n = haystack_len, m = needle_len.
diff --git a/gnu/packages/patches/aegis-perl-tempdir1.patch b/gnu/packages/patches/aegis-perl-tempdir1.patch
new file mode 100644
index 0000000000..9068b98a77
--- /dev/null
+++ b/gnu/packages/patches/aegis-perl-tempdir1.patch
@@ -0,0 +1,14 @@
+This patch removes the hard coded temporary directory (which might not exist on the system)
+and replaces it using the Perl preferred method.
+--- aegis-4.24/script/aebisect.in 2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/script/aebisect.in 2014-01-26 11:03:31.000000000 +0100
+@@ -34,7 +34,8 @@
+ # @configure_input@
+ #
+ # Configure additions?
+-my $TmpDir = "/var/tmp";
++use File::Temp qw/ tempdir /;
++my $TmpDir = tempdir();
+ my $ProgramName = "aebisect";
+
+ require 5.004;
diff --git a/gnu/packages/patches/aegis-perl-tempdir2.patch b/gnu/packages/patches/aegis-perl-tempdir2.patch
new file mode 100644
index 0000000000..244a196fe5
--- /dev/null
+++ b/gnu/packages/patches/aegis-perl-tempdir2.patch
@@ -0,0 +1,18 @@
+--- aegis-4.24/script/aeintegratq.in 2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/script/aeintegratq.in 2014-01-26 16:08:22.000000000 +0100
+@@ -49,13 +49,14 @@
+ #
+ # @configure_input@
+ #
++use File::Temp qw/ tempdir /;
+ # Grab useful locations from configure
+ $BinDir = "@bindir@";
+ # configure does not expand @comdir@ directly so use sharedstatedir
+ $ComDir = "@sharedstatedir@";
+
+ # Configure additions?
+-$TmpDir = "/var/tmp";
++$TmpDir = tempdir();
+ # base mail program that takes all info (to: subj: etc) on stdin
+ $SendMail = "/usr/lib/sendmail";
+ # Define the preferred integration host
diff --git a/gnu/packages/patches/aegis-test-fixup-1.patch b/gnu/packages/patches/aegis-test-fixup-1.patch
new file mode 100644
index 0000000000..1ed4dad525
--- /dev/null
+++ b/gnu/packages/patches/aegis-test-fixup-1.patch
@@ -0,0 +1,15 @@
+This test fails because it expects a MIME type "Content-Type: image/gif"
+whereas that provided by libmagic is "Content-Type: image/gif; charset=binary"
+Presumably the test was written against a different version.
+--- aegis-4.24/test/02/t0228a-matt.sh 2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/test/02/t0228a-matt.sh 2014-01-27 09:43:44.000000000 +0100
+@@ -147,7 +147,8 @@
+ SCRIPT_NAME=/cgi-bin/aeget \
+ PATH_INFO=icon/rss.gif \
+ QUERY_STRING= \
+-$bin/aeget > rss.served.gif 2>&1
++$bin/aeget \
++| sed -e 's%^Content-Type: image/gif; charset=binary%Content-Type: image/gif%' > rss.served.gif 2>&1
+ if test $? -ne 0 ; then fail; fi
+
+ # Compare the expected and the actual received file.
diff --git a/gnu/packages/patches/aegis-test-fixup-2.patch b/gnu/packages/patches/aegis-test-fixup-2.patch
new file mode 100644
index 0000000000..6ba8691ed3
--- /dev/null
+++ b/gnu/packages/patches/aegis-test-fixup-2.patch
@@ -0,0 +1,24 @@
+This test was failing with subversion 1.7.8 because the svn repository structure
+was not as the test expected. Presumably the test relies on different version.
+--- aegis-4.24/test/02/t0222a-pmil.sh 2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/test/02/t0222a-pmil.sh 2014-01-27 19:48:30.000000000 +0100
+@@ -268,7 +268,8 @@
+ -c 10 > log 2>&1
+ if test $? -ne 0 ; then cat log; fail; fi
+
+-test -f $work/svnroot/db/revs/2 || fail
++activity="check svn db 271"
++test -f $work/svnroot/db/revs/0/2 || test -f $work/svnroot/db/revs/2 || fail
+
+ # --------------------------------------------------------------------------
+
+@@ -364,7 +365,8 @@
+ -c 3 > log 2>&1
+ if test $? -ne 0 ; then cat log; fail; fi
+
+-test -f $work/svnroot/db/revs/3 || fail
++activity="check svn db 368"
++test -f $work/svnroot/db/revs/0/3 || test -f $work/svnroot/db/revs/3 || fail
+
+ #
+ # Only definite negatives are possible.