summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-27 15:01:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-27 15:01:38 +0200
commit0306cdd8f5bab73b7dfe50610a243d58f56be579 (patch)
tree8d7fd26d69ae69197e45d34baab74ac466894c46 /gnu/packages/patches
parent083158425914e9a17a241c451a4e254f4656bb02 (diff)
downloadguix-patches-0306cdd8f5bab73b7dfe50610a243d58f56be579.tar
guix-patches-0306cdd8f5bab73b7dfe50610a243d58f56be579.tar.gz
gnu: screen: Update to 4.9.0.
* gnu/packages/screen.scm (screen): Update to 4.9.0. [source]: Remove one patch. [native-inputs]: Remove input labels. Add autoconf, automake. * gnu/packages/patches/screen-CVE-2021-26937.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/screen-CVE-2021-26937.patch66
1 files changed, 0 insertions, 66 deletions
diff --git a/gnu/packages/patches/screen-CVE-2021-26937.patch b/gnu/packages/patches/screen-CVE-2021-26937.patch
deleted file mode 100644
index d87a54a83f..0000000000
--- a/gnu/packages/patches/screen-CVE-2021-26937.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-https://salsa.debian.org/debian/screen/-/raw/debian/4.8.0-5/debian/patches/99_CVE-2021-26937.patch
-
-Description: [CVE-2021-26937] Fix out of bounds array access
-Author: Michael Schröder <mls@suse.de>
-Bug-Debian: https://bugs.debian.org/982435
-Bug: https://savannah.gnu.org/bugs/?60030
-Bug: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00000.html
-Bug-OSS-Security: https://www.openwall.com/lists/oss-security/2021/02/09/3
-Origin: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00010.html
-
---- a/encoding.c
-+++ b/encoding.c
-@@ -43,7 +43,7 @@
- # ifdef UTF8
- static int recode_char __P((int, int, int));
- static int recode_char_to_encoding __P((int, int));
--static void comb_tofront __P((int, int));
-+static void comb_tofront __P((int));
- # ifdef DW_CHARS
- static int recode_char_dw __P((int, int *, int, int));
- static int recode_char_dw_to_encoding __P((int, int *, int));
-@@ -1263,6 +1263,8 @@
- {0x30000, 0x3FFFD},
- };
-
-+ if (c >= 0xdf00 && c <= 0xdfff)
-+ return 1; /* dw combining sequence */
- return ((bisearch(c, wide, sizeof(wide) / sizeof(struct interval) - 1)) ||
- (cjkwidth &&
- bisearch(c, ambiguous,
-@@ -1330,11 +1332,12 @@
- }
-
- static void
--comb_tofront(root, i)
--int root, i;
-+comb_tofront(i)
-+int i;
- {
- for (;;)
- {
-+ int root = i >= 0x700 ? 0x801 : 0x800;
- debug1("bring to front: %x\n", i);
- combchars[combchars[i]->prev]->next = combchars[i]->next;
- combchars[combchars[i]->next]->prev = combchars[i]->prev;
-@@ -1396,9 +1399,9 @@
- {
- /* full, recycle old entry */
- if (c1 >= 0xd800 && c1 < 0xe000)
-- comb_tofront(root, c1 - 0xd800);
-+ comb_tofront(c1 - 0xd800);
- i = combchars[root]->prev;
-- if (c1 == i + 0xd800)
-+ if (i == 0x800 || i == 0x801 || c1 == i + 0xd800)
- {
- /* completely full, can't recycle */
- debug("utf8_handle_comp: completely full!\n");
-@@ -1422,7 +1425,7 @@
- mc->font = (i >> 8) + 0xd8;
- mc->fontx = 0;
- debug3("combinig char %x %x -> %x\n", c1, c, i + 0xd800);
-- comb_tofront(root, i);
-+ comb_tofront(i);
- }
-
- #else /* !UTF8 */