summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/xmonad-next-dynamic-linking.patch
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-01-10 01:54:25 +0000
committerLars-Dominik Braun <lars@6xq.net>2022-01-17 20:29:39 +0100
commit5387a9c00ef2f972c32ab4430a3f1879131b1652 (patch)
tree1e07e1196baa0ce62c1a5109b867d0cbee6fe745 /gnu/packages/patches/xmonad-next-dynamic-linking.patch
parent723aa8b391cf1633963f1c2f466e1904d81e3e54 (diff)
downloadguix-patches-5387a9c00ef2f972c32ab4430a3f1879131b1652.tar
guix-patches-5387a9c00ef2f972c32ab4430a3f1879131b1652.tar.gz
gnu: Add xmonad-next and ghc-xmonad-contrib-next.
Fixes: <https://issues.guix.gnu.org/issue/52784>. * gnu/packages/wm.scm (xmonad-next): New variable. Compared to xmonad: Update to 0.17.0. [inputs]: Add GHC-DATA-DEFAULT-CLASS, remove GHC-EXTENSIBLE-EXCEPTIONS, GHC-DATA-DEFAULT, GHC-SEMIGROUPS, and GHC-UTF8-STRING. [native-inputs]: Add GHC-QUICKCHECK and GHC-QUICKCHECK-CLASSES. (ghc-xmonad-contrib-next): New variable. Compared to ghc-xmonad-contrib: Update to 0.17.0. [propagated-inputs]: Remove GHC-OLD-TIME, GHC-EXTENSIBLE-EXCEPTIONS, GHC-SEMIGROUPS. [native-inputs]: Add GHC-QUICKCHECK and GHC-HSPEC. (xmonad): Inherit from xmonad-next. (ghc-xmonad-contrib): Inherit from ghc-xmonad-contrib-next. * gnu/packages/patches/xmonad-next-dynamic-linking.patch: New patch. Update of xmonad-dynamic-linking.patch to apply to xmonad-next. * gnu/local.mk: Add it. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/patches/xmonad-next-dynamic-linking.patch')
-rw-r--r--gnu/packages/patches/xmonad-next-dynamic-linking.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/xmonad-next-dynamic-linking.patch b/gnu/packages/patches/xmonad-next-dynamic-linking.patch
new file mode 100644
index 0000000000..a1d71825b6
--- /dev/null
+++ b/gnu/packages/patches/xmonad-next-dynamic-linking.patch
@@ -0,0 +1,16 @@
+This patch is required for xmonad to make use of shared libraries.
+Without it, xmonad will not work since we do not (by default) use
+statically linked Haskell libraries.
+
+index 46a0939..5ad4f8f 100644
+--- a/src/XMonad/Core.hs
++++ b/src/XMonad/Core.hs
+@@ -664,6 +664,8 @@ compile dirs method =
+ where
+ ghcArgs = [ "--make"
+ , "xmonad.hs"
++ , "-dynamic"
++ , "-fPIC"
+ , "-i" -- only look in @lib@
+ , "-ilib"
+ , "-fforce-recomp"