summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/x265-detect512-all-arches.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-15 11:33:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-15 11:40:34 +0300
commitb7028a16e6fe4f9634cd7d550b3a79450fc4e0db (patch)
treea51f6cd30133cb6d5e8915eea3446bffda57ea8c /gnu/packages/patches/x265-detect512-all-arches.patch
parent2d5fa80e83190b6bdbeb8a45e68a885b283e2490 (diff)
downloadguix-patches-b7028a16e6fe4f9634cd7d550b3a79450fc4e0db.tar
guix-patches-b7028a16e6fe4f9634cd7d550b3a79450fc4e0db.tar.gz
gnu: x265: Fix building on armhf-linux and aarch64-linux.
* gnu/packages/video.scm (x265)[source]: Update list of patches. [arguments]: Change configure flag to ensure PIC for all architectures. * gnu/packages/patches/x265-arm-asm-primitives.patch: Remove file. * gnu/packages/patches/x265-detect512-all-arches.patch: New file. * gnu/local.mk (dist_patch_DATA): Update patch registry.
Diffstat (limited to 'gnu/packages/patches/x265-detect512-all-arches.patch')
-rw-r--r--gnu/packages/patches/x265-detect512-all-arches.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/x265-detect512-all-arches.patch b/gnu/packages/patches/x265-detect512-all-arches.patch
new file mode 100644
index 0000000000..4d39d868fd
--- /dev/null
+++ b/gnu/packages/patches/x265-detect512-all-arches.patch
@@ -0,0 +1,37 @@
+https://sources.debian.org/data/main/x/x265/2.9-3/debian/patches/0003-detect512-is-needed-on-all-architectures.patch
+
+From: Adam Sampson <unknown@bitbucket>
+Date: Sun, 14 Oct 2018 14:04:18 +0200
+Subject: detect512 is needed on all architectures
+
+---
+ source/common/cpu.cpp | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
+index 0681ff5..fa687da 100644
+--- a/source/common/cpu.cpp
++++ b/source/common/cpu.cpp
+@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
+ { "", 0 },
+ };
+
++bool detect512()
++{
++ return(enable512);
++}
++
+ #if X265_ARCH_X86
+
+ extern "C" {
+@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
+ #pragma warning(disable: 4309) // truncation of constant value
+ #endif
+
+-bool detect512()
+-{
+- return(enable512);
+-}
+ uint32_t cpu_detect(bool benableavx512 )
+ {
+