summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/wicd-get-selected-profile-fix.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-12 00:20:16 -0400
committerMark H Weaver <mhw@netris.org>2015-08-12 00:22:02 -0400
commitae4784af544a9d667c95cae6af5b6e5d146af66b (patch)
tree8a75658d052f482010ab3c00cc0d6d09bd551e93 /gnu/packages/patches/wicd-get-selected-profile-fix.patch
parent1e738fc8a59580c1fb7fd2d437ce78f8a70412db (diff)
downloadguix-patches-ae4784af544a9d667c95cae6af5b6e5d146af66b.tar
guix-patches-ae4784af544a9d667c95cae6af5b6e5d146af66b.tar.gz
gnu: wicd: Fix bugs in curses interface program.
* gnu/packages/patches/wicd-bitrate-none-fix.patch, gnu/packages/patches/wicd-get-selected-profile-fix.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/wicd.scm (wicd)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/wicd-get-selected-profile-fix.patch')
-rw-r--r--gnu/packages/patches/wicd-get-selected-profile-fix.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/wicd-get-selected-profile-fix.patch b/gnu/packages/patches/wicd-get-selected-profile-fix.patch
new file mode 100644
index 0000000000..3042a87308
--- /dev/null
+++ b/gnu/packages/patches/wicd-get-selected-profile-fix.patch
@@ -0,0 +1,16 @@
+Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2
+
+--- wicd-1.7.3/curses/wicd-curses.py 2014-12-21 16:57:33 +0000
++++ wicd-1.7.3/curses/wicd-curses.py 2015-02-24 23:41:01 +0000
+@@ -532,7 +532,10 @@
+ def get_selected_profile(self):
+ """Get the selected wired profile"""
+ loc = self.get_focus()[1]
+- return self.theList[loc]
++ if len(self.theList) > loc:
++ return self.theList[loc]
++ else:
++ return self.theList[-1]
+
+
+ class AdHocDialog(Dialog2):