summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-05 18:45:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-05 19:33:10 +0200
commit1860b4152360a18ac562690c1f541e53537bf262 (patch)
tree47e408c17c4b574ae74561b1ec9e0bd50dd8a260 /gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
parent53428597a690b409cdb66070ca4397ed76015e20 (diff)
downloadguix-patches-1860b4152360a18ac562690c1f541e53537bf262.tar
guix-patches-1860b4152360a18ac562690c1f541e53537bf262.tar.gz
gnu: websocketpp: Update to 0.8.2.
* gnu/packages/web.scm (websocketpp): Update to 0.8.2. [source]: Replace patch. * gnu/packages/patches/websocketpp-fix-for-boost-1.70.patch: Delete file. * gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch')
-rw-r--r--gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch b/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
new file mode 100644
index 0000000000..ea759d022b
--- /dev/null
+++ b/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
@@ -0,0 +1,17 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Fri, 05 Jun 2020 18:37:51 +0200
+Subject: [PATCH] gnu: websocketpp: Fix build with CMake >= 3.15.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 57ed01e78..43c772d78 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -215,7 +215,7 @@
+ set (Boost_USE_MULTITHREADED TRUE)
+ set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
+
+- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
++ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
+
+ if (Boost_FOUND)
+ # Boost is a project wide global dependency.