summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-02 17:51:21 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 10:57:30 +0200
commit0b5bf61573c5491a52dfb70ea2b6e91ca61ef199 (patch)
treecfbee9cb4e86da1ef33ce85807d29ace6b186eaf /gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch
parenta4be14261cff5770f490172668373c1b0bb60235 (diff)
downloadguix-patches-0b5bf61573c5491a52dfb70ea2b6e91ca61ef199.tar
guix-patches-0b5bf61573c5491a52dfb70ea2b6e91ca61ef199.tar.gz
gnu: Add warsow-qfusion.
* gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch: New file. * gnu/local.mk: Include patch. * gnu/packages/game-development.scm (warsow-qfusion): New variable.
Diffstat (limited to 'gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch')
-rw-r--r--gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch b/gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch
new file mode 100644
index 0000000000..ec22377446
--- /dev/null
+++ b/gnu/packages/patches/warsow-qfusion-fix-bool-return-type.patch
@@ -0,0 +1,22 @@
+diff --git a/source/ref_gl/r_imagelib.cpp b/source/ref_gl/r_imagelib.cpp
+index 418028a..f76916b 100644
+--- a/source/ref_gl/r_imagelib.cpp
++++ b/source/ref_gl/r_imagelib.cpp
+@@ -762,7 +762,7 @@ static void q_jpg_noop( j_decompress_ptr cinfo ) {
+
+ static boolean q_jpg_fill_input_buffer( j_decompress_ptr cinfo ) {
+ Com_DPrintf( "Premature end of jpeg file\n" );
+- return 1;
++ return TRUE;
+ }
+
+ static void q_jpg_skip_input_data( j_decompress_ptr cinfo, long num_bytes ) {
+@@ -955,7 +955,7 @@ bool WriteJPG( const char *name, r_imginfo_t *info, int quality ) {
+ }
+
+ // start compression
+- qjpeg_start_compress( &cinfo, true );
++ qjpeg_start_compress( &cinfo, TRUE );
+
+ // feed scanline data
+ w3 = cinfo.image_width * info->samples;