summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vtk-7-python-compat.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 23:43:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:06 -0400
commit607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0 (patch)
tree6b802b21618ced9de8bc94bf7cc9f713879d2072 /gnu/packages/patches/vtk-7-python-compat.patch
parent17375266ea2e94726bf3d28c1d4fb3899c115377 (diff)
downloadguix-patches-607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0.tar
guix-patches-607e48ba3ccb038e2fa4b956cb62ce628cdc8cd0.tar.gz
gnu: Add vtk-7.
* gnu/packages/image-processing.scm: (vtk-7): New variable. * gnu/packages/patches/vtk-7-gcc-10-compat.patch: New patch. * gnu/packages/patches/vtk-7-hdf5-compat.patch: Likewise. * gnu/packages/patches/vtk-7-python-compat.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them.
Diffstat (limited to 'gnu/packages/patches/vtk-7-python-compat.patch')
-rw-r--r--gnu/packages/patches/vtk-7-python-compat.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/vtk-7-python-compat.patch b/gnu/packages/patches/vtk-7-python-compat.patch
new file mode 100644
index 0000000000..375624e4e2
--- /dev/null
+++ b/gnu/packages/patches/vtk-7-python-compat.patch
@@ -0,0 +1,16 @@
+Author: Gert Wollny <gewo@debian.org>
+Description: Work around compile bug with python 3.7.1
+Debian-Bug: https://bugs.debian.org/914347
+diff --git a/Wrapping/PythonCore/vtkPythonArgs.cxx b/Wrapping/PythonCore/vtkPythonArgs.cxx
+index 1b1e4b9..682f8b8 100644
+--- a/Wrapping/PythonCore/vtkPythonArgs.cxx
++++ b/Wrapping/PythonCore/vtkPythonArgs.cxx
+@@ -102,7 +102,7 @@ bool vtkPythonGetStringValue(PyObject *o, T *&a, const char *exctext)
+ else if (PyUnicode_Check(o))
+ {
+ #if PY_VERSION_HEX >= 0x03030000
+- a = PyUnicode_AsUTF8(o);
++ a = const_cast<char*>(PyUnicode_AsUTF8(o));
+ return true;
+ #else
+ PyObject *s = _PyUnicode_AsDefaultEncodedString(o, NULL);