summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-11 15:52:45 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-11 16:33:50 +0100
commitef0f0d5f971bf9c7a755b6b5c4bda34fc50e1987 (patch)
treee59390154b2db7f2e4ce7c9c588d16781fc95f09 /gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
parentbaacf042fd2b82699e6952a7cee536e8254b5826 (diff)
downloadguix-patches-ef0f0d5f971bf9c7a755b6b5c4bda34fc50e1987.tar
guix-patches-ef0f0d5f971bf9c7a755b6b5c4bda34fc50e1987.tar.gz
gnu: vorbis-tools: Patch buffer overflow [fixes CVE-2015-6749].
* gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xiph.scm (vorbis-tools)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch')
-rw-r--r--gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch b/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
new file mode 100644
index 0000000000..bcddcbfd70
--- /dev/null
+++ b/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
@@ -0,0 +1,44 @@
+Upstream fix for CVE-2015-6749.
+https://trac.xiph.org/ticket/2212
+
+From 04815d3e1bfae3a6cdfb2c25358a5a72b61299f7 Mon Sep 17 00:00:00 2001
+From: Mark Harris <mark.hsj@gmail.com>
+Date: Sun, 30 Aug 2015 05:54:46 -0700
+Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input
+
+Fixes #2212
+---
+ oggenc/audio.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/oggenc/audio.c b/oggenc/audio.c
+index 477da8c..4921fb9 100644
+--- a/oggenc/audio.c
++++ b/oggenc/audio.c
+@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
+ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ {
+ int aifc; /* AIFC or AIFF? */
+- unsigned int len;
+- unsigned char *buffer;
++ unsigned int len, readlen;
++ unsigned char buffer[22];
+ unsigned char buf2[8];
+ aiff_fmt format;
+ aifffile *aiff = malloc(sizeof(aifffile));
+@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ return 0; /* Weird common chunk */
+ }
+
+- buffer = alloca(len);
+-
+- if(fread(buffer,1,len,in) < len)
++ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
++ if(fread(buffer,1,readlen,in) < readlen ||
++ (len > readlen && !seek_forward(in, len-readlen)))
+ {
+ fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
+ return 0;
+--
+2.5.0
+