summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vigra-python-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-08 21:35:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:05 +0100
commita82e6faa8b993d1f3b47a8bd22c4509f7cae7ec1 (patch)
treef13d579ca7dfff820ea3b369c4b030bc132f398d /gnu/packages/patches/vigra-python-compat.patch
parent2ac164a8107dbb07ba1ed29986859d3e936f795a (diff)
downloadguix-patches-a82e6faa8b993d1f3b47a8bd22c4509f7cae7ec1.tar
guix-patches-a82e6faa8b993d1f3b47a8bd22c4509f7cae7ec1.tar.gz
gnu: vigra: Build with Python 3.
* gnu/packages/patches/vigra-python-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (vigra)[source](patches): New field. [inputs]: Change PYTHON-2 and PYTHON2-NUMPY to PYTHON and PYTHON-NUMPY. [native-inputs]: Change from PYTHON2-NOSE to PYTHON. [arguments]: Adjust #:configure-flags accordingly.
Diffstat (limited to 'gnu/packages/patches/vigra-python-compat.patch')
-rw-r--r--gnu/packages/patches/vigra-python-compat.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/vigra-python-compat.patch b/gnu/packages/patches/vigra-python-compat.patch
new file mode 100644
index 0000000000..63c6abb326
--- /dev/null
+++ b/gnu/packages/patches/vigra-python-compat.patch
@@ -0,0 +1,18 @@
+Fix build with Boost + Python 3.7.
+
+Taken from upstream:
+https://github.com/ukoethe/vigra/commit/a6fa62663c6a6b752ed0707e95f643e25867a0f9
+
+diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx
+index ec38d3636..c81c6ae52 100644
+--- a/vigranumpy/src/core/vigranumpycore.cxx
++++ b/vigranumpy/src/core/vigranumpycore.cxx
+@@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s)
+ return checksum(data, size);
+ #else
+ Py_ssize_t size = 0;
+- char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
++ const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
+ return checksum(data, size);
+ #endif
+ }