summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vboot-utils-skip-test-workbuf.patch
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-12-30 09:46:29 -0500
committerKei Kebreau <kkebreau@posteo.net>2019-01-03 15:40:27 -0500
commitb634b5c253cb3351eb074c64be838f72aa83f54d (patch)
treedf833ca2f81bd4c4152e4d0ea2595b451e57efb4 /gnu/packages/patches/vboot-utils-skip-test-workbuf.patch
parent824fc425dd1f3d366ff950874e09fdc8c8e4f4b2 (diff)
downloadguix-patches-b634b5c253cb3351eb074c64be838f72aa83f54d.tar
guix-patches-b634b5c253cb3351eb074c64be838f72aa83f54d.tar.gz
gnu: vboot-utils: Fix building on armhf-linux.
* gnu/packages/bootloaders.scm (vboot-utils)[source]: Add patches. [arguments]: Conditionally add "HOST_ARCH=arm" to #:make-flags. * gnu/packages/patches/vboot-utils-fix-format-load-address.patch, gnu/packages/patches/vboot-utils-fix-tests-show-contents.patch, gnu/packages/patches/vboot-utils-skip-test-workbuf.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/vboot-utils-skip-test-workbuf.patch')
-rw-r--r--gnu/packages/patches/vboot-utils-skip-test-workbuf.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/vboot-utils-skip-test-workbuf.patch b/gnu/packages/patches/vboot-utils-skip-test-workbuf.patch
new file mode 100644
index 0000000000..9618c76f83
--- /dev/null
+++ b/gnu/packages/patches/vboot-utils-skip-test-workbuf.patch
@@ -0,0 +1,21 @@
+This patch was copied from Debian.
+
+Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16
+Author: Sophie Brun <sophie@freexian.com>
+Last-Update: 2015-12-03
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/tests/vb2_common_tests.c
++++ b/tests/vb2_common_tests.c
+@@ -70,6 +70,11 @@ static void test_workbuf(void)
+ /* NOTE: There are several magic numbers below which assume that
+ * VB2_WORKBUF_ALIGN == 16 */
+
++ /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */
++ if (VB2_WORKBUF_ALIGN != 16) {
++ return;
++ }
++
+ /* Init */
+ vb2_workbuf_init(&wb, p0, 64);
+ TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned");