summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/unzip-CVE-2015-7696.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-22 14:54:43 -0400
committerMark H Weaver <mhw@netris.org>2015-10-23 23:12:06 -0400
commit51de92a08e11b11ac9e5bbb2938be2ad0de02d80 (patch)
tree6203b6bfb46a4fc9541d3f9922ba5c59c295115d /gnu/packages/patches/unzip-CVE-2015-7696.patch
parentd3365d486636b36c95ce17deefbc169f3d4f0e9a (diff)
downloadguix-patches-51de92a08e11b11ac9e5bbb2938be2ad0de02d80.tar
guix-patches-51de92a08e11b11ac9e5bbb2938be2ad0de02d80.tar.gz
gnu: unzip: Reorganize security fixes for improved clarity.
* gnu/packages/patches/unzip-fix-overflows-and-infloop.patch: Delete file. Its contents are now split into the following new files: * gnu/packages/patches/unzip-CVE-2015-7696.patch, gnu/packages/patches/unzip-CVE-2015-7697.patch, gnu/packages/patches/unzip-overflow-on-invalid-input.patch: New files. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/zip.scm (unzip)[source]: Adjust patches accordingly.
Diffstat (limited to 'gnu/packages/patches/unzip-CVE-2015-7696.patch')
-rw-r--r--gnu/packages/patches/unzip-CVE-2015-7696.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/unzip-CVE-2015-7696.patch b/gnu/packages/patches/unzip-CVE-2015-7696.patch
new file mode 100644
index 0000000000..d6a4072673
--- /dev/null
+++ b/gnu/packages/patches/unzip-CVE-2015-7696.patch
@@ -0,0 +1,35 @@
+Copied from Debian.
+
+From: Petr Stodulka <pstodulk@redhat.com>
+Date: Mon, 14 Sep 2015 18:23:17 +0200
+Subject: Upstream fix for heap overflow
+Bug-Debian: https://bugs.debian.org/802162
+Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944
+Origin: https://bugzilla.redhat.com/attachment.cgi?id=1073002
+Forwarded: yes
+
+---
+ crypt.c | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+--- a/crypt.c
++++ b/crypt.c
+@@ -465,7 +465,17 @@
+ GLOBAL(pInfo->encrypted) = FALSE;
+ defer_leftover_input(__G);
+ for (n = 0; n < RAND_HEAD_LEN; n++) {
+- b = NEXTBYTE;
++ /* 2012-11-23 SMS. (OUSPG report.)
++ * Quit early if compressed size < HEAD_LEN. The resulting
++ * error message ("unable to get password") could be improved,
++ * but it's better than trying to read nonexistent data, and
++ * then continuing with a negative G.csize. (See
++ * fileio.c:readbyte()).
++ */
++ if ((b = NEXTBYTE) == (ush)EOF)
++ {
++ return PK_ERR;
++ }
+ h[n] = (uch)b;
+ Trace((stdout, " (%02x)", h[n]));
+ }