summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tomb-fix-errors-on-open.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-11-12 17:11:49 -0600
committerEric Bavier <bavier@member.fsf.org>2019-11-15 14:59:07 -0600
commit4535eb91c399cf6b3d151751be170ca3b3df122f (patch)
tree683e4a4af51f16117ec6d3f44a1a2fa22c48cd0c /gnu/packages/patches/tomb-fix-errors-on-open.patch
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadguix-patches-4535eb91c399cf6b3d151751be170ca3b3df122f.tar
guix-patches-4535eb91c399cf6b3d151751be170ca3b3df122f.tar.gz
gnu: tomb: Update to 2.7.
* gnu/packages/patches/tomb-fix-errors-on-open.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/crypto.scm (tomb): Update to 2.7. [source]: Use the patch.
Diffstat (limited to 'gnu/packages/patches/tomb-fix-errors-on-open.patch')
-rw-r--r--gnu/packages/patches/tomb-fix-errors-on-open.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/tomb-fix-errors-on-open.patch b/gnu/packages/patches/tomb-fix-errors-on-open.patch
new file mode 100644
index 0000000000..5f41c9ee8f
--- /dev/null
+++ b/gnu/packages/patches/tomb-fix-errors-on-open.patch
@@ -0,0 +1,25 @@
+Description: Avoid error messages when opening a new tomb
+ Make sure control file exists and has user ownership before user writes to it.
+Author: Sven Geuer <debmaint@g-e-u-e-r.de>
+Bug: https://github.com/dyne/Tomb/issues/369
+Last-Update: 2019-11-04
+--- a/tomb
++++ b/tomb
+@@ -2197,14 +2197,15 @@
+ # {{{ Open
+
+ _update_control_file() {
+- # replaces a control file with new contents and gives it user ownership
++ # make sure a control file exists, gives it user ownership
++ # and replaces it with new contents
+ # stdin = contents
+ # $1 = path to control file
+ # $2 = contents
+ [[ "$2" = "" ]] && return 1
+ _sudo touch "$1"
+- print "$2" > "$1"
+ _sudo chown ${_UID}:${_GID} "$1"
++ print "$2" > "$1"
+ _verbose "updated control file $1 = $2"
+ }
+