summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tinyxml-use-stl.patch
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-11-24 13:35:44 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-11-25 11:44:11 -0500
commit33ae9107d8b60c8c418bc0b7c6ee17af99c85e2f (patch)
tree6007680685dd7a09669491b98cd7f5c5b9a8cfe9 /gnu/packages/patches/tinyxml-use-stl.patch
parent968ae903189c6c4a41c0e2cddf41ffc5a8c32f93 (diff)
downloadguix-patches-33ae9107d8b60c8c418bc0b7c6ee17af99c85e2f.tar
guix-patches-33ae9107d8b60c8c418bc0b7c6ee17af99c85e2f.tar.gz
gnu: Add tinyxml.
* gnu/packages/xml.scm (tinyxml): New variable. * gnu/packages/patches/tinyxml-use-stl.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/tinyxml-use-stl.patch')
-rw-r--r--gnu/packages/patches/tinyxml-use-stl.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/patches/tinyxml-use-stl.patch b/gnu/packages/patches/tinyxml-use-stl.patch
new file mode 100644
index 0000000000..5d8aa899a9
--- /dev/null
+++ b/gnu/packages/patches/tinyxml-use-stl.patch
@@ -0,0 +1,41 @@
+From a53b6ee4519a7657164610ac14a82c57b1273bf6 Mon Sep 17 00:00:00 2001
+From: David Thompson <dthompson2@worcester.edu>
+Date: Mon, 23 Nov 2015 06:54:36 -0500
+Subject: [PATCH] Use STL.
+
+Software that uses the shared library, such as Kodi, assume that TinyXML was
+compiled with STL activated.
+
+---
+ tinyxml.h | 2 ++
+ xmltest.cpp | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/tinyxml.h b/tinyxml.h
+index a3589e5..6cbfc7d 100644
+--- a/tinyxml.h
++++ b/tinyxml.h
+@@ -43,6 +43,8 @@ distribution.
+ #define DEBUG
+ #endif
+
++#define TIXML_USE_STL 1
++
+ #ifdef TIXML_USE_STL
+ #include <string>
+ #include <iostream>
+diff --git a/xmltest.cpp b/xmltest.cpp
+index 663c157..057dbfe 100644
+--- a/xmltest.cpp
++++ b/xmltest.cpp
+@@ -2,6 +2,7 @@
+ Test program for TinyXML.
+ */
+
++#define TIXML_USE_STL 1
+
+ #ifdef TIXML_USE_STL
+ #include <iostream>
+--
+2.5.0
+