summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/texinfo-5-perl-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-31 17:05:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-01 12:56:52 +0200
commita446cf26d7f386a81b8667f5ec75fb5f6232d202 (patch)
treec8fb4fcc135f6eb832a6f4cced9ee5df7c7bafc1 /gnu/packages/patches/texinfo-5-perl-compat.patch
parent16de7f15cb2e9111916542dd538286d50086f100 (diff)
downloadguix-patches-a446cf26d7f386a81b8667f5ec75fb5f6232d202.tar
guix-patches-a446cf26d7f386a81b8667f5ec75fb5f6232d202.tar.gz
gnu: texinfo@5: Fix FTBFS with Perl >= 5.28.
* gnu/packages/patches/texinfo-5-perl-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/texinfo.scm (texinfo-5)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches/texinfo-5-perl-compat.patch')
-rw-r--r--gnu/packages/patches/texinfo-5-perl-compat.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/texinfo-5-perl-compat.patch b/gnu/packages/patches/texinfo-5-perl-compat.patch
new file mode 100644
index 0000000000..f16d6b4da8
--- /dev/null
+++ b/gnu/packages/patches/texinfo-5-perl-compat.patch
@@ -0,0 +1,19 @@
+Fix a deprecation warning with newer Perl that breaks some tests.
+
+--- a/tp/Texinfo/Parser.pm
++++ b/tp/Texinfo/Parser.pm
+@@ -5438,12 +5438,12 @@
+ }
+ } elsif ($command eq 'clickstyle') {
+ # REMACRO
+- if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) {
++ if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) {
+ $args = ['@'.$1];
+ $self->{'clickstyle'} = $1
+ unless(_ignore_global_commands($self));
+ $remaining = $line;
+- $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
++ $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
+ $has_comment = 1 if (defined($4));
+ } else {
+ $self->line_error (sprintf($self->__(